2 Replies Latest reply on Apr 2, 2014 11:17 AM by averagejoe77

    Could not complete the Crop command because of a program error - Win 7

    averagejoe77 Level 1

      So I use PS CC everyday for cropping out images from design mockups for websites.

       

      Yesterday (1 April 2014) I got a new comp from the designer with some updated images. So I opend the comp, and began to setup the cropped area with my guides. I then grabbed the marquee tool and made my selection, clicked Image->Crop, and then I get an error message.

       

      "Could not complete the Crop command because of a program error."

       

      Well that is helpful.

       

      So now its "Help me Google, you're my only hope.", after about an hour or so of searching this error I find that it mostly happens to Mac users. I am using Windows 7. I also find that people are trying to get information form a PSErrorLog.txt file that is suppsoed to be located in the "Preferences Folder"... again I am on Windows 7.

       

      So more searching to find the Windows eqivelant of this file's location: C:\Users\{USERNAME}\AppData\Roaming\Adobe\Adobe Photoshop CC\Adobe Photoshop CC Settings

       

      Only to find there is no PSErrorLog.txt file. I do have a sniffer-out.txt file and a bunch of .psp files, a SynchFiles folder and 2 Workspaces folders (one Modified).

       

      So I say to myself, "Well, I have cloud and a fast connection, won't take long to reinstall." So I delete PS ( I am also runnig DW, FL, Br, and AI ), and PS only. I do not run the cleaner tool as it only wants to delete a PS driver, or EVERYTHING!, which I do not want to do, I just want to delete PS. So I delete PS and check for anything left behind (why is there always stuff left behind? Apparently DELETE really means "Only delete some parts of the app that are required to make it work, and leave the rest behind.", or something.). Anyway, I then reinstall, go to crop again, and get the same error.

       

      So here I am, "Help me Adobe Forums, you're my only hope."

        • 1. Re: Could not complete the Crop command because of a program error - Win 7
          Mylenium Most Valuable Participant

          You have written a lot, but said very little. We don't know anything about your documents like color modes, color profiles, what makes up the layers, dimensions, layer styles used and so on. Quite likely the issue is somehow related to that - your colleague may have opened the file and changed the color profile or something like a vector-based smart object cannot be cropped without destroying it.

           

          Mylenium

          • 2. Re: Could not complete the Crop command because of a program error - Win 7
            averagejoe77 Level 1

            Mylenium,

             

            You are correct. But none of that information, or those parameters, have ever had any effect on cropping anything in PS before. I crop vector smart objects brought in from AI all the time. In this case, yes the layers I am trying to crop are vector smart objects, which I rasterized and merged, then resaved the document and still get the same issue.

             

            But, going off of your suggestion, I did flatten the image completely and I am now able to crop it without error. I suspect that there is something else in the layers that maybe causing this issue, as you have mentioned.

             

            Thank you for your input, while you may not have known it, you gave me at least somewhere to start to try and figure out what is happening.