4 Replies Latest reply on Apr 4, 2014 9:13 AM by joel@studio-229.com

    Multiprocessing works for RAM preview, extremely slow and aeselflink crashes when in Render Queue

    joel@studio-229.com Level 1

      Hello all,

       

      System specs:

      Hackintosh

      OSX 10.9

      3.5Ghz (overclocked to 4.2Ghz) Core i7

      Geforce GTX 580 classified 3GB Cuda GPU

      AMD Radeon HD 6870 1GB Display GPU

      32 GB of RAM

      System SSD

      5 drive internal RAID

      After Effects CC 12.2.1.5

      Cuda drivers up to date

       

       

      I'm having a problem with the render queue and multiprocessing. I have a moderate sequence with several effects and 3D layers. When I'm working in the composition, everything goes great. I can RAM preview and all my CPU cores will kick up to 100% and render the composition in no time all; with full resolution with no skipped frames. It works fantastically.

       

      Then when I go to render the exact same composition with the same multiprocessing settings, AE will hang at the "initializing background processes" for at least 5-10 minutes, during which the CPU will ramp up to 100% but no frames will be rendered. AE still remains responsive, as I can hit the stop or pause buttons and the queue will be cancled. But then the aeselflink processes (up to 8 of them depending on my settings, I've tried several) will still continue at 100% cpu load even with AE not set to render anything. I will have to go into the activity monitor and force quit each process. If I leave it for 5-10 minutes, it will finally stop initalizing and start the render, but the CPU will still run at 100% but the frames will crawl slowly forward at about 1 frame per minute, with an estimated 28 hours to render frames that were rendering in under a minute during RAM preview.

       

      I have tried both reducing the number of cores AE will use, adjusting the allocated RAM, and disabling multiprocessing alltogether. When I disable multiprocessing, the render slows to a complete crawl, and it will render around 1 frame every 5-10 seconds. Again, this is on a composition that rendered in less than a minute on full resolution with RAM preview.

       

      The only way to get this composition to render is to export it to Media Encoder, which will render it (without multicore processing, unfortunately) in about 8 minutes, still not the blazing fast RAM preview but at least it finishes it in under 3.5 hours (the amount of time that the multiprocessing disabled render in AE will take).

       

      Screen Shot 2014-04-04 at 8.50.07 AM.png

      Here's the multiprocessing settings that have been very stable and carried me through other projects. Disk Cache is not enabled. The only other thing that is disabled is the "Disable Layer Cache" under the Secret menu as the plugins I'm using (Plexus 2 in this case) doesn't like to update when the camera moves so this option has been disabled to force it to reset each frame.

       

      Does anyone know what is going on?

       

      Also, please don't tell me that I should not use multiprocessing or instruct me on basic steps as to increase preformance on my machine. I have been tweaking my memory and multiprocessing settings for a long time now, and it is completely stable in everything but this setup. So please no answers saying "just don't use multiprocessing". It was made for a reason, it's effective, and it's needed. And please don't say that it's the hackintosh, either, as it's the most stable and powerful computer I've ever used. Sorry for the disclaimers, I just want to have constructive help.

       

      Thank you in advance for your ideas!