6 Replies Latest reply on Apr 7, 2014 8:10 AM by ThinkingThings

    Problems trying to change Display to High Quality

    ThinkingThings Level 1

      Hi,

       

      I am trying to change my display to High Quality in a script after I create a document. I am aware of the limitations having to do with previously placed images, but the InDesign menu item isn't even getting checked to the High Quality Display. I have tried moving to a MenuACtion, but I am having problems with that too... :-( Is there any reason why this shouldn't work? I am not getting any error = it is just not doing anything.

       

      (where app = InDesign Application):

       

      app.DisplayPerformancePreferences.DefaultDisplaySettings =  idViewDisplaySettings.idHighQuality

       

      Thanmks in advance!

       

      -TT

      CS6  VB.NET  WIN7

        • 1. Re: Problems trying to change Display to High Quality
          Dave Saunders Level 4

          That doesn't work for the same reason that the same action in the UI doesn't work: changing that preference only affects future windows not exsiting ones.

           

          You need to use the viewDisplaySetting property of the front layoutWIndow (translated into VB).

           

          Dave

          • 2. Re: Problems trying to change Display to High Quality
            ThinkingThings Level 1

            Hi Dave,

             

            Actually it DOES work in the UI... that's what I don't understand. Am I missing something else?

             

            -TT

            • 3. Re: Problems trying to change Display to High Quality
              Dave Saunders Level 4

              Hate to be contrary, but it doesn't work in the UI if you're expecting it to affect existing windows. It never has and is one of the most confusing aspects of InDesign preferences.

               

              The solution, for an existing layout window is to set the viewDisplaySetting property of that window.

               

              Dave

              • 4. Re: Problems trying to change Display to High Quality
                ThinkingThings Level 1

                Howdy Again, Dave.

                 

                First of all, Yahoo!!! on the viewDisplaySetting! After my reply, I googled viewDisplaySetting and you are correct on the SCRIPT fix: here's the VB code:

                 

                  app.ActiveWindow.ViewDisplaySetting =  idViewDisplaySettings.idHighQuality

                 

                So MANY, MANY thanks for that. When some of my hair grows back in, I'll retry the MenuAction attempt to get to the "High Quality Display" on the Menu -- which brings me to my second point... Like I said, the UI High Quality Display DOES work (at least for me), which was why I considered trying to get to it via a MenuAction in the first place after being initially unsuccessful. Had the UI "not" worked, I wouldn't have even pursued the MenuAction approach. I certainly respect your startement, but I'm just throwing this out there for what it's worth. Now here's a caveat -- my "images" are usually AI imports, so maybe THAT makes a difference.

                 

                Once, again, though, thank you for your help.

                 

                Kindest regards,

                 

                TT

                • 5. Re: Problems trying to change Display to High Quality
                  Dave Saunders Level 4

                  When people have this kind of disagreement, it usually means they're talking about different things. So, to be clear:

                   

                  In the UI, the equivalent of your:

                   

                  app.DisplayPerformancePreferences.DefaultDisplaySettings =  idViewDisplaySettings.idHighQuality

                   

                  Is to go to InDesign/Preferences/Display Performance/Options and choose High Quality. This affects only future windows and not current ones.

                   

                  However, the UI also allows you, with a layout window at front to go to: View/Display Performance/High Quality Display. And this works on the current window. This is the equivalent of the scripting action:

                   

                  app.ActiveWindow.ViewDisplaySetting =  idViewDisplaySettings.idHighQuality

                   

                  Does that clear up the difference of opinion?

                   

                  Dave

                   

                  PS: I realize that as a Mac user I've used the Mac path to InDesign Preferences. I believe this is slightly different on Windows.

                  • 6. Re: Problems trying to change Display to High Quality
                    ThinkingThings Level 1

                    Hi Dave,

                     

                    Thanks for your reply.

                     

                    "When people have this kind of disagreement, it usually means they're talking about different things."

                     

                    I certainly agree with you on that. All along, when I was referring to the UI equivalent, I was speaking of View > Display Performance > High Quality Display, and (incorrectly) trying to accomplish that with change with:

                     

                       app.DisplayPerformancePreferences.DefaultDisplaySettings = idViewDisplaySettings.idHighQuality

                     

                     

                    In my OP, I mentioned "I am trying to change my display to High Quality in a script after I create a document" and what I meant was that I was looking to change the quality of the display in front of me, despite trying to fix it with an incorrect script line. Sorry for the confusion. So when you said:

                    "That doesn't work for the same reason that the same action in the UI doesn't work"

                     

                    I believe that is where the misunderstanding began. The UI equivalent that you were referring to at that point was (on PC) Edit > Preferences > Display Performance and changing Options:Display to High Quality, thereby changing the defaults.

                     

                    Anyway, I really do appreciate your patience and understanding, and above all, your time in helping with this. I understand the nuances much better now.

                     

                    Thanks again, Dave.

                     

                    -TT