7 Replies Latest reply on Jun 11, 2007 10:05 AM by Newsgroup_User

    COLDFUSION 7 & WINDOWS VISTA

    pope on acid
      Software: Coldfusion 7.0.2, Flex Builder 2.
      Operating System: Windows Vista.

      This is my very last try to get Flex working. I tried a dozen of sample apps I've downloaded and I always get the same error when I want to run the apps. A lot of issues hereabout on the Internet, but no working solution!

      The error information in FB2:

      Debug Panel:
      http://localhost/QueryToDatagrid/bin/QueryToDatagrid-debug.html
      Main Thread (Suspended: [RPC Fault faultString="[MessagingError message='Unknown destination 'Coldfusion'.']" faultCode="InvokeFailed" faultDetail="Couldn't establish a connection to 'Coldfusion'"])
      mx.rpc.remoting.mxml::RemoteObject/dispatchEvent
      mx.rpc::AbstractOperation/ http://www.adobe.com/2006/flex/mx/internal::dispatchRpcEvent
      Function/ http://adobe.com/AS3/2006/builtin::apply [no source]
      mx.rpc::AsyncDispatcher/mx.rpc:AsyncDispatcher::timerEventHandler
      flash.utils::Timer/flash.utils:Timer::_timerDispatch [no source]
      flash.utils::Timer/flash.utils:Timer::tick [no source]

      Console:
      [SWF] /QueryToDatagrid/bin/QueryToDatagrid-debug.swf - 850.118 bytes after decompression
      [RPC Fault faultString="[MessagingError message='Unknown destination 'Coldfusion'.']" faultCode="InvokeFailed" faultDetail="Couldn't establish a connection to 'Coldfusion'"]
      at mx.rpc::AbstractInvoker/ http://www.adobe.com/2006/flex/mx/internal::invoke()[C:\dev\enterprise_bali\frameworks\mx\ rpc\AbstractInvoker.as:230
      at mx.rpc.remoting.mxml::Operation/ http://www.adobe.com/2006/flex/mx/internal::invoke()[C:\dev\enterprise_bali\frameworks\mx\ rpc\remoting\mxml\Operation.as:167
      at mx.rpc.remoting::Operation/send()[C:\dev\enterprise_bali\frameworks\mx\rpc\remoting\Opera tion.as:120]
      at Function/ http://adobe.com/AS3/2006/builtin::apply()
      at mx.rpc.remoting.mxml::Operation/send()[C:\dev\enterprise_bali\frameworks\mx\rpc\remoting\ mxml\Operation.as:144]
      at Function/ http://adobe.com/AS3/2006/builtin::apply()
      at mx.rpc::AbstractService/ http://www.adobe.com/2006/actionscript/flash/proxy::callProperty()[C:\dev\enterprise_bali\ frameworks\mx\rpc\AbstractService.as:287
      at QueryToDatagrid/QueryToDatagrid::initApp()[C:\inetpub\wwwroot\QueryToDatagrid\QueryToData grid.mxml:14]
      at QueryToDatagrid/___Application1_creationComplete()[C:\inetpub\wwwroot\QueryToDatagrid\Que ryToDatagrid.mxml:2]
      at flash.events::EventDispatcher/flash.events:EventDispatcher::dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at mx.core::UIComponent/dispatchEvent()[C:\dev\flex_201_gmc\sdk\frameworks\mx\core\UICompone nt.as:8323]
      at mx.core::UIComponent/set initialized()[C:\dev\flex_201_gmc\sdk\frameworks\mx\core\UIComponent.as:1095]
      at mx.managers::LayoutManager/mx.managers:LayoutManager::doPhasedInstantiation()[C:\dev\flex _201_gmc\sdk\frameworks\mx\managers\LayoutManager.as:696]
      at Function/ http://adobe.com/AS3/2006/builtin::apply()
      at mx.core::UIComponent/mx.core:UIComponent::callLaterDispatcher2()[C:\dev\flex_201_gmc\sdk\ frameworks\mx\core\UIComponent.as:7909]
      at mx.core::UIComponent/mx.core:UIComponent::callLaterDispatcher()[C:\dev\flex_201_gmc\sdk\f rameworks\mx\core\UIComponent.as:7852]

      Note: Last week I went to the Flex 2: Rich Internet Applications voor Designers jumpstart in Belgium and no one in the classroom (including the 'teacher') was able to get the COLDFUSION-FLEX combination working (neither on a Mac, Win XP or Win Vista system); Not my idea of a good start.

      I will check this thread again in one week from here (when I am back from holiday). Then I will decide if I wanna go one with Flex or not.

        • 1. Re: FLEX - COLDFUSION - CFC
          BLXWebMaster Level 1
          What is the actual Remote Object Code that you are trying to run that is generating the error?

          • 2. Re: FLEX - COLDFUSION - CFC
            pope on acid Level 1
            To keep it simple, I used the Coldfusion wizard in FB2 and create a simple master/detail page.
            The RDS Configuration in FB2 is OK and I view the table in FB2 through RDS Dataview.

            But when I run the application I get the following error:

            (mx.rpc::Fault)#0
            errorID = 0
            faultCode = "Client.Error.MessageSend"
            faultDetail = "Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Status 404: url: ' http://localhost/flex2gateway/'"
            faultString = "Send failed"
            message = "faultCode:Client.Error.MessageSend faultString:'Send failed' faultDetail:'Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Status 404: url: ' http://localhost/flex2gateway/''"
            name = "Error"
            rootCause = (Object)#1
            code = "NetConnection.Call.Failed"
            description = "HTTP: Status 404"
            details = " http://localhost/flex2gateway/"
            level = "error"
            • 3. Re: FLEX - COLDFUSION - CFC
              BLXWebMaster Level 1
              O.K. That is helpful.

              Step one make sure you can browse to http://localhost/flex2gateway. You should get a blank page and nothing else.

              If you get the blank page, then we need to drill down further. If you do not, there is an issue there. Try replacing localhost with your actual IP address. Did you setup the gateway to run on a different port?

              Allen


              • 4. Re: FLEX - COLDFUSION - CFC
                pope on acid Level 1
                On both localhost and 127.0.0.1 I get the 404 page not found error.
                I did the same test on a WinXP station, where it works fine.

                So it seems to be a compability problem with Windows Vista.

                Don't know if it is a Coldfusion or a Flexbuilder issue, but I hope this problem will be solved in the next releases so I can go on testing Flexbuilder.

                In the mean time I will stay with CF and the integrated Flash Forms.

                Thanks for your help anyway.

                Regards,

                Alex

                • 5. Re: FLEX - COLDFUSION - CFC
                  BLXWebMaster Level 1
                  Giving Up?

                  Well if you are interested. Could be an issue with your connector.

                  What web server are you running? What port is CF running on?

                  If running IIS... You can try reinstalling t he connector.

                  Run CFusionMX7\bin\connectors\Remove_ALL_connectors.bat
                  Then
                  CFusionMX7\bin\connectors\IIS_connector.bat

                  • 6. COLDFUSION 7 & WINDOWS VISTA
                    pope on acid Level 1
                    The problem is I have a few projects with a short deathline for the moment.
                    But guess what, I mentioned that Coldfusion 8 Beta was available.
                    Installed on Vista it runs perftect! And so do the sample applications.

                    Problem Solved: Coldfusion MX7, even with all the fixes , doesn't run like it should on Windows Vista.

                    Thanks for your time and to encourage me not to give up :)
                    • 7. Re: FLEX - COLDFUSION - CFC
                      Level 7
                      What is the "Gateway" that I see mentioned from time to time? I've asked
                      this before with no answer and that is, "How do you configure MX 7.02 for
                      use with Flex?". I have an unanswered thread titled, "Is MX 7.02 ready for
                      flash remoting and flex?" so the answer appears to be "Who Knows?"

                      I'm in the same boat. Been trying to get Flex to work with Coldfusion MX
                      7.02 as a proof of concept, but after many hours, it has only proven to be a
                      difficult and undocumented process. Too bad because all the apps look very
                      cool. But maybe it means it is time to investigate JavaFX?

                      "BLXWebMaster" <webforumsuser@macromedia.com> wrote in message
                      news:f3i10b$j6p$1@forums.macromedia.com...
                      O.K. That is helpful.

                      Step one make sure you can browse to http://localhost/flex2gateway. You
                      should get a blank page and nothing else.

                      If you get the blank page, then we need to drill down further. If you do
                      not,
                      there is an issue there. Try replacing localhost with your actual IP
                      address.
                      Did you setup the gateway to run on a different port?

                      Allen