20 Replies Latest reply: May 9, 2014 11:24 AM by ChadM RSS

    Why do some images not import with the html pages

    ChadM Community Member

      Some images import and others do not. The only way to make them appear them is to delete the topic and reimport it. As a result the table of contents always has to be redone. This occurs for random topics each time I start Robohelp 10, so you never know what is and is not missing until compiled.

       

      I have a series of 1500 page projects and this is extremely inefficient.

        • 1. Re: Why do some images not import with the html pages
          Peter Grainge CommunityMVP

          Import from where?

           

          Which version of RoboHelp? Rh11?

           

          RoboHelp HTML or RoboHelp for Word?

           


          See www.grainge.org for RoboHelp and Authoring tips

           

           

          @petergrainge

          • 2. Re: Why do some images not import with the html pages
            ChadM Community Member

            Hi Peter and thanks for taking the time to respond.

             

            I’ve used Robohelp even before it was called that, way bay to Blue Sky software, then Macromedia and am now up to Adobe version 10 for HTML.

             

            I have a series of projects that I maintain; they are on our network, as is the Robohelp program. The projects are laid out with a main folder, then subfolders for each section. I then import the html files into Robohelp from Windows 7 using the Project Manager, opening HTML Files (topics) folder, then right clicking on each folder and using the Import… option to navigate to the location on the network and import the html file.

             

            The problem is that random files seem to be losing the images that have been linked (imbedded in the html pages) or are just not including the images, even though the images are properly inserted in the html pages, and are included in the source folders on the network. The only way to have these images show up in Robohelp is to delete the html page from Robohelp and reimport. This is random so I never know which pages are missing images until compiled. I have at least 4 major projects with pages ranging from 200-1500 in total so this is difficult to maintain.

             

            I can’t think of anything I’m doing differently than I have done for the past 15 years.  My supervisor is adamant that we forget Robohelp and use Atlassian Confluence and I am trying hard to hold my ground. It’s becoming more difficult to make the argument to upgrade to version 11 when I’m spending so much time retracing my steps.

             

            If there is any help you could offer that would be very much appreciated.

             

            Chad

            • 3. Re: Why do some images not import with the html pages
              Captiv8r CommunityMVP

              Hi Chad

               

              Hopefully Peter won't mind my popping in.

               

              First, just an observation. I too go back to Blue Sky days. I started with RoboHelp version 2 and I never have known it to be referred to by any other name.

               

              As to the issue, I know that it's possible to create HTML pages with other tools (even the venerable Windows Notepad) and when working that way it's possible to refer to things in odd ways. Perhaps there was an absolute link to an image and during the process of importing, RoboHelp is having problems resolving the folder.

               

              In these cases, when you notice the situation happening, it would be interesting to just look at the HTML code of the page in question to see exactly how the image is being referenced. Perhaps that would provide a clue as to why RoboHelp may be having issues.

               

              Another thing to consider is that the project is on the network. I know RoboHelp 10 is "sort of okay" with projects on networks, but that could likely be a huge factor here. Even though it's still supposed to be "okay" to have your RoboHelp projects on a network, I still regularly advise folks to try and keep projects on their local C drive if at all possible.

               

              Cheers... Rick

              • 4. Re: Why do some images not import with the html pages
                Peter Grainge CommunityMVP

                Seriously, Rh is installed to a network drive and always has been? From Rh10 it has been OK to have the projects on a network drive but it never has been OK to install Rh to a network drive and still is not.

                 

                The network will be on a different and unsupported operating system and you will not be the user.

                 

                Atlassian Confluence is a completely different type of program.

                 


                See www.grainge.org for RoboHelp and Authoring tips

                 

                 

                @petergrainge

                • 5. Re: Why do some images not import with the html pages
                  ChadM Community Member

                  Hi Rick,

                   

                  Thanks so much for your feedback.

                   

                  The network, ah yes, I mentioned that very sheepishly knowing well and good I am taking my chances there but locally installed I have issues between Corel X6 and Robohelp, I know not why but they don’t play well in the same sandbox. I may end up moving Corel and installing Robohelp locally.

                   

                  As for the image solution possibility you suggested, yes I completely understand your point. The strange thing is that when I reimport the same file using the same images the problem is fixed.

                   

                  I am starting to lean towards the network causing the problem. Since day 1 (and that’s a loooong time ago) the network never has been an issue so that’s why I didn’t really consider it a problem.

                  • 6. Re: Why do some images not import with the html pages
                    ChadM Community Member

                    Yes, I’ve never had an issue in all these years. The source files are all located in the same place as Robohelp on the network and everyone has played very well in the sandbox. I have my own windows 7 box that I log on to that runs everything and only I access the box (robohelp licensing).

                     

                    I mentioned to Rick that I have issues with Corel and Robohelp not playing well together on my local drive so that’s why it’s installed in the network. I guess I will have to work with the IT guys and change things around if you think that is the issue.

                    • 7. Re: Why do some images not import with the html pages
                      Peter Grainge CommunityMVP

                      Ah, you are talking about a virtual machine on the network? That is different and should be OK.

                       

                      I think what I would do though is copy the whole project to your local machine and have Rh installed there as well. Your licence allows two installs but you only need it in trial mode to see if that makes a difference.

                       

                      If you then still have the problem, we'll need to dig deeper but if it then works...

                       

                      I assume you have tried the old trick of deleting the CPD file and reopening the project? If not try that but backup first.

                       


                      See www.grainge.org for RoboHelp and Authoring tips

                       

                       

                      @petergrainge

                      • 8. Re: Why do some images not import with the html pages
                        ChadM Community Member

                        Hi Peter,

                        I just spoke to our IT manager and that is in fact how it is set up.

                        I think I will have them set up a separate Corel box for me and I will uninstall Robohelp and move it to my local drive.

                        Apologies in advance if this solves the issue.

                         

                        Chad

                        • 9. Re: Why do some images not import with the html pages
                          Peter Grainge CommunityMVP

                          No apology needed. You had a problem and the forum has helped you get on the right road. That is what it is for.

                           

                          Rh should be OK on a virtual machine, I have used it that way, so I wouldn't uninstall at this stage. Just install on the second machine for now.

                           


                          See www.grainge.org for RoboHelp and Authoring tips

                           

                           

                          @petergrainge

                          • 10. Re: Why do some images not import with the html pages
                            ChadM Community Member

                            Hi Peter,

                             

                            A lot has happened since we last spoke.

                             

                            I kept seeing missing images so i bit the bullet and made a brand new project - one full week of reimporting, a new TOC and all new context IDs.Now it is holding images properly: Phase 1 done.

                             

                            No luck with compiling Webhelp on the virtual machine for which I have full administrator rights - no table of contents shows. When I compile across the network it works perfectly. Go figure!  Phase 2 done (mostly)

                             

                            The big issue is that I cannot for the life of me compile a CHM keeps giving a microsoft compile error. I've gone through the forum and tried removing the CMD file still no luck on either the virtual location or the network (i know the network is a complete no no but it works for my Webhelp). No files have special characters, I make a point of keeping them simple.

                             

                            Anyhow if you have any insight gems as to what I can try I would be forever grateful.

                             

                            Thanks a lot

                            Chad

                            • 11. Re: Why do some images not import with the html pages
                              ChadM Community Member

                              Can I ask does and underscore count as a special character _  ?

                              If so then I have a lot of work to do...

                               

                              Thanks

                              Chad

                              • 12. Re: Why do some images not import with the html pages
                                RoboColum(n) MeganK

                                Hi Chad.

                                 

                                Not sure if this helps but it maybe worth checking that the Microsoft HTML Help compiler (that RH uses to build CHMs) is fully installed on the virtual machine. There is a diagnostics report that you can run. It is available here:

                                 

                                HTML Help Diagnostics

                                 

                                If you still have issues, perhaps you can give us more details of the compile error.

                                The good news is that underscores are OK in file names.

                                • 13. Re: Why do some images not import with the html pages
                                  ChadM Community Member

                                  Hi and thanks so much for taking the time to respond.

                                   

                                  Fantastic news re underscore. I have 4 main projects, ranging 500 to 1200 pages each. Scary thought hit me as i was writing earlier

                                  .

                                  I will grab the IT team tomorrow morning to look into your suggestion. Really hoping this works and thanks again,

                                   

                                  chad

                                  • 14. Re: Why do some images not import with the html pages
                                    ChadM Community Member

                                    Hello,

                                     

                                    Great news, the compiler was ok on our virtual site however I noticed one gif file had an extra "." in it and once that was removed it compiled perfectly on the virtual box.

                                     

                                    I would to ask though why the Webhelp output does not include the TOC, and it does work across the network. Ideally I would like to move all my projects to the virtual box but not until I can compile with a TOC.

                                     

                                    Any thoughts??

                                     

                                    Thanks

                                    Chad

                                    • 15. Re: Why do some images not import with the html pages
                                      Captiv8r CommunityMVP

                                      Chad, when you view the WebHelp, is there a place for a TOC but it's empty? Or are you only seeing the topic content filling the page?

                                       

                                      Cheers... Rick

                                      • 16. Re: Why do some images not import with the html pages
                                        ChadM Community Member

                                        There is a place but it is blank

                                        • 17. Re: Why do some images not import with the html pages
                                          ChadM Community Member

                                          Also, if you click the x in the TOC area it closes the section.

                                           

                                          Thanks Rick,

                                          C

                                          • 18. Re: Why do some images not import with the html pages
                                            Captiv8r CommunityMVP

                                            Hello again

                                             

                                            See if the article linked below helps with that.

                                             

                                            Click here to view

                                             

                                            Cheers... Rick

                                            • 19. Re: Why do some images not import with the html pages
                                              ChadM Community Member

                                              Hi Rick,

                                              I’m going to give this a go asap. I’m out soon for the day so am not ignoring if I don’t reply back today.

                                              Much appreciated!!

                                              C

                                              • 20. Re: Why do some images not import with the html pages
                                                ChadM Community Member

                                                It works.

                                                You rock!

                                                 

                                                Have a great weekend.

                                                 

                                                Chad