5 Replies Latest reply on Apr 11, 2014 4:47 AM by Peter Spier

    How to activate text box

    YoleKara

      What to do when the text box does not work?  When I select text tool.  I can type but there is no text box so I cannot move it, resize it or edit text.  Help please.

        • 1. Re: How to activate text box
          Laubender Adobe Community Professional & MVP

          @YoleKara – this is a very, very basic stuff.

          InDesign is not a text processor like MS Word.

          Do not expect InDesign to function like that.

           

          Here the solution:
          After selecting the text tool draw a text frame by holding the left mouse button and drag a rectangle shape. If you release the mouse button a text frame is created and the insertion point of that text frame is selected. Just type in text then…

           

          You can do that on a page or in the area around a page (the pasteboard).

           

          There is no live text without a text frame or a graphic object where text can be set on a path.

           

          A text frame need not to be a rectangle. It can be any shape. You can convert any shape to a text frame by clicking with the text tool into that shape (provided you did not change the standard behavior of InDesign in the Preferences).

           

          Uwe

          • 2. Re: How to activate text box
            [Jongware] Most Valuable Participant

            From the description it sounds like the text box has been accidentally locked

             

            To check: right-click with the text box selected, look in the popup menu for "Lock Position" / "Unlock Position". Do Not Change when it says "Lock Position" as this is a command, not a state.

            • 3. Re: How to activate text box
              Laubender Adobe Community Professional & MVP

              @Jongware – ah, yes… Could well be that.


              But in that case the text frame is not selectable (a setting in the General Preferences of InDesign).

               

              YoleKara could then  unlock all locked elements on the whole spread with the apropriate menu command or keyboard shortcut combination alt + cmd + L (for InDesign on Mac OSX). And/or change the preferences for locked elements in General Preferences.

               

              Uwe

              • 4. Re: How to activate text box
                Peter Spier Most Valuable Participant (Moderator)

                Besides changing the prefs to allow selection of locked objects (that's a stupid default, not to be able to), one can ALWAYS lock or unlock any object in the Layers panel without needing to affect any other objects on the spread.

                • 5. Re: How to activate text box
                  Peter Spier Most Valuable Participant (Moderator)

                  YoleKara wrote:

                   

                  I can type but there is no text box so I cannot move it, resize it or edit text.  Help please.

                  This sounds to me more like frame edges are hidden. If you are in Preview mode, either exit Preview mode or set the prefs to show frame edges when you pass over them with the Selection tool (or just click where you think the frame is). If in Normal view you don't see frame edges, check the settings in the View menu.