0 Replies Latest reply on Apr 11, 2014 7:26 AM by Timothy DM

    TOC Book Not Working Properly

    Timothy DM Level 1

      Offering this info for anyone else who might run into a similar situation.  When reviewing the browse sequence for an RH 10 project, I noticed one topic (page) displaying where a TOC book should have been.  The topic being displayed was the topic associated with the book, but the book's subtopics were not being displayed.  The topic being displayed for the book included a link to a subtopic listed for the book in the RH project, but the link was dead.  The link for the topic worked fine when using the CTRL+W to view the topic from RH.  To resolve the issue, I tried deleting and re-adding the book.  Recompiled.  No change.  I repositioned the book (it happened to begin with the same few words as the two previously listed books, and I wanted to eliminate the possibilty of an issue based on beginning multiple books with the same text).  No change.  Deleted .cpd file (it was over 5MB), opened the project to recreate .cpd file, and then recompiled again.  No change. Copied and pasted text from all topics involved into new topics of the same screen name but assigned new .htm page names (so topic text and screen names were identical).  Updated links to match newly created topics.  Re-added book to TOC.  Recompiled.  This worked.  TOC book now displayed with subtopics, and link from main topic to subtopic was functional again.  Anyone else run into something like this, where a TOC book did not display correctly, possibly as a result of a corrupt topic/page within the book that appeared to work fine in RH project?