3 Replies Latest reply on Sep 14, 2016 9:02 PM by elliottmsmss

    License problem with automation.swc and mxmlc

    Martin van Vliet Level 1

      We are currently migrating our flex application from flex 3.6 to flex 4.6 framework. To functionally test our application, we use RIAtest. RIAtest uses the automation.swc library to test the user interface automatically. automation.swc seems to be a proprietary library and you need a Flash Builder Premium license. We have such a license for Flash Builder 4 Premium. We do not really use flash builder to develop, but we use build scripts to trigger the mxmlc directly from ANT. The build scripts pass the license to the mxmlc compiler using the license flag. This all worked perfectly when we used flex 3 SDK. We use the SDKs that were included in the Flash Builder distribution.

       

      But now we try to migrate our application to flex 4 SDK. Everything compiles and runs, we solved a minor amount of issues for that. But automatically testing the application with RIAtest does not work. After a few seconds we get the error:

       

      "License not present. With trial version only limited replays are allowed"

       

      Which turns out to be caused by the automation library not accepting our license. But we are unable to solve the issue. We tried everything possible but the mxmlc compiler is just IGNORING our license. The license should be valid, it works perfectly with flex 3 SDK. But with flex 4, we get the error described above while testing. The mxmlc compiler does not give any feedback AT ALL what is wrong with the license.

       

      We now pass in the license like this, but we tried many variations.

       

      '-license=flashbuilder4,"xxxx-xxxx-xxxx-xxxx-xxxx-xxxx"'

       

      • We use the Flex SDK version 3.6.0 and Flex SDK version 4.6.0 both installed by Flash Builder version 4.
      • We use a volume license for flash builder. When i try to register the volume license in my adobe account it also does not accept it. Although we can use it to register flashbuilder. Maybe this is part of the problem

       

      We have the following questions:

      • How can we solve this issue?
      • How do we debug what is going wrong because mxmlc is giving no feedback?
      • How can I validate my license?

       

      I found multiple topics on this forum similair to this problem, but they where all about licensing in general. We only have problems with SDK 4.

       

      Regards, Martin