7 Replies Latest reply on May 31, 2007 2:06 PM by Peter Grainge

    RH 5 Application error

    donna_mb2006
      I am using RH5. I tried to remove a folder from a project, RH locked up, I had to close. I tried to open the file again and was not able to open it. I rebooted. I made several attempts and got the “sorry for the inconvenience error message.”

      I uninstalled RH and reinstalled. I can open the project, but first I get a message telling me that the folder that I tried to delete is missing and that all of the files in that folder are missing (which is fine because there is nothing in it).

      I still get the error message about the missing folder, when I click OK the project appears to be fine. However, when I attempt to do anything in the file I get an Application Error:

      The instruction at 0x73dd11c7 referenced memory at 0x00000004.’ The memory could not be “read.” Click OK to terminate the program.


      I can open other projects. I do not have a recent backup for the project I am having trouble with.

      Any ideas?
        • 1. Re: RH 5 Application error
          RoboColum(n) Level 5
          Have you checked that the project is NOT located on a network drive and that you have installed RH with full administrator rights?
          • 2. Re: RH 5 Application error
            donna_mb2006 Level 1
            It is located on my hard drive. As far as the Administrative rights- I am not sure what you mean by that. I installed it as I dis in the past and everything worked fine.

            I also get new error message:
            AppName: robohtml.exe AppVer: 13.0.584.0 ModName: mdbms.dll
            ModVer: 13.0.584.0 Offset: 000eb97f
            • 3. Re: RH 5 Application error
              Peter Grainge Adobe Community Professional (Moderator)
              Take a copy of this project before you try anything else.

              Then take a look at the topic on my site about Opening Projects. Maybe deleting the CPD and XPJ files, then opening the project from the HHP file will help.

              I am assuming we are talking about RH HTML here.

              • 4. Re: RH 5 Application error
                donna_mb2006 Level 1
                I tried the method described on Peter’s site.
                I removed the XPJ and CPD files. (I also tried renaming them becuse for some strange reason they came back after RH crashed).
                I even deleted all of the Frame.htms from the project.
                When I tried to open from the HHP file, it choked even before the project opened.

                Any other ideas?
                • 5. Re: RH 5 Application error
                  Peter Grainge Adobe Community Professional (Moderator)
                  Frame.htms? Is there something you are not telling us? Not files I am familiar with in my RoboHelp work.

                  The XPJ and CPD files will be recreated when opening from the HHP file, possibly even if it does lock up.

                  How big is this project zipped up and is it something you can send me? Don't email it. Let me know the size first.



                  • 6. Re: RH 5 Application error
                    donna_mb2006 Level 1
                    In your article it says:

                    "Any Exceptions?
                    The only reported exception was one poster whose project used framesets; the project choked if she tried to open it via the hhp file.

                    Click here if you have problems. The cause of your hhp file choking may not be the same but the solution may still be valid.

                    Occasionally deleting the cpd and xpj files might not quite work as Teri White found out with "framed" htm files in the project. When Teri tried that, she found the project just choked.

                    RH Support responded that they could recreate a cpd for a project with frames, it appeared it might be something unique to Teri's project. In a posting on the old forums, on 13 Jun 2004 Teri advised

                    *****************************

                    The solution for this problem has been found! Through plain dumb luck I happened to try rebuilding the .hhp file stopping at a 'framed' .htm file - one created with RH as a 3 pane frame. It failed. Hmmm....removed that file AND found the other one I have that's a 2 pane frame from the .hhp and tried opening the file.

                    Voila! - it worked!

                    So...in X5 IF you have any 'framed' .htm files and you want to erase the .cpd file and rebuild from the .hhp file like days of old...you first have to remove these from the .hhp (in Notepad). Then it opens just fine."

                    I retried what is above and it worked this time....

                    Lesson learned- back up on heard drive when your company is having severe network storage problems!

                    Thanks for you help!


                    • 7. Re: RH 5 Application error
                      Peter Grainge Adobe Community Professional (Moderator)
                      Ah! The lady who makes the most amazing chocolates. I had forgotten that one. You have no idea how long was spent working on that project so Teri sent me a box of her home made chocolates. They were the devil's creation.

                      I guess you will frame that answer! Sorry, it is late here.