1 Reply Latest reply on Apr 21, 2014 12:15 PM by csgaraglino

    CF9 New Search Engine Issues?

    csgaraglino Level 1

      I have an older application that I have upgraded and I am only having issues with the Search Engine going form Verity to Solr.

       

      I have a simple query tht gets the content for each page and indexes it. The code works awesome in Varity - but when I run it on the Solr system I get the following error:

       

      Error_opening_new_searcher_exceeded_limit_of_maxWarmingSearchers4_try_again_later

       

      Also - when this errors out (only this error) - the prowser shows the HTML Source of the error instead of the typical?

       

      Any help, please!

       

      There are only 207 records that I am trying to index?

      between 20-25 actually get indexed.

       

       

      <cfindex action="PURGE" collection="#application.stSiteData.objectCollection#">

       

                  <cfquery name="qGetData" datasource="#application.stSiteData.datasource#">

                      SELECT  objectID

                      FROM Objects

                      WHERE active = 1

                  </cfquery>

       

              <cfset myList = valueList(qGetData.objectID)>

       

              <cfloop list="#myList#" index="xobjectID">

                  <CFQUERY name="qGetObjectData" datasource="#application.stSiteData.datasource#">

                      SELECT        *

                      FROM            objects INNER JOIN

                                              Pages ON objects.pageID = Pages.pageID

                      WHERE            Pages.exSiteSearch <> 1

                              and  objects.objectID = '#xobjectID#'

                  </CFQUERY>

       

                  <cfindex action="UPDATE"

                      collection="#application.stSiteData.objectCollection#"

                      key="objectID"

                      query="qGetObjectData"

                      type="CUSTOM"

                      title="label"

                      body="label,objectData"

                      custom1="pageid"

                      custom2="">

              </cfloop>

        • 1. Re: CF9 New Search Engine Issues?
          csgaraglino Level 1

          So I am still working on this and it seems that it's some kinf of Commit issue?

          I don't understand why I can index 200 records without CF crashing? Thiis doens seem logical that the new SE would be such a POS?

           

          I have tried updated the XML config form 4 to 8 - all that I could find, but I am still getting the same error that you see above - so Im not sure that changing that setting did anything?

           

          This seems like there is a simple answer somewhere - I can't be the only one on these boards that is having issues?