8 Replies Latest reply on Aug 30, 2014 8:41 PM by A.T. Romano

    Premiere Elements 12 crashes on launch

    Ehpem

      I am trying to install and use PE12 for the first time. I have read many of the threads about this but have run to a dead end so any help would be appreciated.

       

      On loading it gets as far as Loading ImporterQuickTime.prm and then fails. It is a purchased download with the Elements 12 bundle (Element works fine).

       

      I have uninstalled and reinstalled Quicktime.

      I have uninstalled and reinstalled PE12

      I have uninstalled older versions of other Adobe software (this is the first time I have tried Premiere Elements)

      I have tried a newer video driver, and rolled back to a driver that dates prior to July 2013.

      I have removed the 12.0 folder in C:\Users\User\AppData\Roaming\Adobe\Premiere Elements

      I have disabled the firewall, MS Security Essentials and Malwarebytes.

       

      I probably have done other things too since I have been struggling with this for 4 hours. Not impressed that this is an issue going back to PE7 at least and there is no good Adobe help that can be found on this.

       

      System:

      Win7 64 bit (SP1)

      Quad Core Q8400 2.67 GHz

      NVidia GeForce GT240

      5 gb RAM

      Drives:

           Kingston SVP200S37A2 - 103 gb free

           WDC WD10 EALX-009BA0 - 359 gb free

           WDC WD10 EARS-00Y5B1 - 695 gb free

           WDC WD1002FAEX-007BA - 884 gb free

           HL-DT-ST DVDRAM GSA-H62N ATA

       

       

      Thanks for any help anyone can provide.