1 Reply Latest reply on Apr 25, 2014 2:15 AM by PXC

    Unable to install extension on AI CC on Mac

    poortip87 Level 1

      Hi All,

       

      I am developing an extension for AI CS6 and CC for Win and Mac. My extension is a hybrid extension. Below are the contents of my mxi file.

       

      <?xml version="1.0" encoding="UTF-8" standalone="no"?>

      <macromedia-extension id="MyExt" name="MyExt" requires-restart="true" version="3.1">

        <author name="Unknown"/>

        <description/>

        <license-agreement/>

        <products>

          <product bit="32" familyname="Illustrator" maxversion="17.9" primary="true" version="16.0"/>

          <product bit="64" familyname="Illustrator" maxversion="17.9" primary="true" version="16.0"/>

        </products>

        <files>

                  <file destination="$plugin" file-type="plugin" maxVersion="17.9" minVersion="17.0" platform="mac" products="Illustrator" source="CC/Mac/MyExt.aip"/>

                <file destination="$plugin" file-type="plugin" maxVersion="16.9" minVersion="16.0" platform="mac" products="Illustrator" source="CS6/Mac/MyExt.aip"/>

                <file destination="$plugin" file-type="plugin" maxVersion="16.9" minVersion="16.0" platform="win" products="Illustrator32" source="CS6/Win/32Bit/MyExt.aip"/>

                <file destination="$plugin" file-type="plugin" maxVersion="16.9" minVersion="16.0" platform="win" products="Illustrator64" source="CS6/Win/64Bit/MyExt.aip"/>

                <file destination="$plugin" file-type="plugin" maxVersion="17.9" minVersion="17.0" platform="win" products="Illustrator32" source="CC/Win/32Bit/MyExt.aip"/>

                <file destination="$plugin" file-type="plugin" maxVersion="17.9" minVersion="17.0" platform="win" products="Illustrator64" source="CC/Win/64Bit/MyExt.aip"/>

        </files>

      </macromedia-extension>

       

      The installation on my Windows 7 goes well on both the Illustrator versions and my extension and plugins are installed properly. But on my Mac machine (OS X 10.6.8), when I try to install the zxp on AI CC, the Extension Manager CC gives the error message,

      "This extension cannot be installed, it requires Illustrator version in range of inclusively between 16.0 and 17.9"

       

      Now, I don't understand this because my AI CC version is 17.1.0 and Extension Manager version is 7.1.1.32

      Interestingly, the extension is installed properly without any errors on AI CS6 on the same machine. Extension Manager version is 6.0.0.412 and AI CS6 version is 16.0.0.

       

      Please guide.

        • 1. Re: Unable to install extension on AI CC on Mac
          PXC Level 2

          I would add "mac" to the <products> section:

           

            <products>

              <product familyname="Illustrator" maxversion="17.9" primary="true" version="16.0" platform="mac"/>

              <product bit="32" familyname="Illustrator" maxversion="17.9" primary="true" version="16.0"/>

              <product bit="64" familyname="Illustrator" maxversion="17.9" primary="true" version="16.0"/>

            </products>