15 Replies Latest reply on May 14, 2014 7:27 AM by steve patterson

    Open EXR Channel Caching Options Broken?

    steve patterson

      Hi!

       

      It's been awhile! Nice to be back on the ole' stomping grounds!

       

      I'm a bit confused as to where the Open EXR channel caching functionality has gone. If I select my 32-bit Open EXR sequence in the project window and choose to interpret it, when I click on "more options", I don't get any floating window with which to populate settings. I have the most recent version of ProEXR installed (not that it should matter, I believe). I'm using the latest version of Mavericks, and the most up-to-date CC edition. I've even tried editing the preferences manaully, but I get an error thrown back when I try to launch AE with the modified preferences:

       

      prefs.png

      error.png

      FWIW, I tried shooting Brendan an email, but haven't heard back. Is this a known issue?

       

      Best,

      -Steve

      (-stev=o)

      (timeRemapper)

        • 1. Re: Open EXR Channel Caching Options Broken?
          steve patterson Level 1

          Also, if you're having problems testing because you don't have an Open EXR file or sequence, please let me know and perhaps I can send you one.

           

          Thanks,

          -Steve

          • 2. Re: Open EXR Channel Caching Options Broken?
            Tim Kurkoski Adobe Employee

            steve patterson wrote:

             

            I've even tried editing the preferences manaully, but I get an error thrown back when I try to launch AE with the modified preferences:

             

            That problem is clear from your screenshots. Notice that the quotes around your edited values are curly left/right quote characters, not the standard straight quotes. This is because in Mac OS 10.9, Apple enables some "Smart" Substitutions on by default.

             

            In TextEdit, choose Edit > Substitutions > Smart Quotes to disable this for a single document. Open the TextEdit preferences to disable it by default for that application. To disable it for all applications, System Preferences > Keyboard> Text.

             

            In regards to your actual problem, this is not a known issue. When you click the More Options button, could the dialog possibly be hidden or off-screen? Does After Effects stop responding to clicks at that point, but pressing Enter or Escape on the keyboard puts you back in a working state?

             

            Have you tried resetting the After Effects preferences and/or plist file?

             

            Is this only a problem with a particular EXR sequence, or does the problem occur with all EXR sequences? What about a single EXR file?

            1 person found this helpful
            • 3. Re: Open EXR Channel Caching Options Broken?
              steve patterson Level 1

              Thanks for the reply, Tim.

               

              That's pretty naughty of 10.9...implementing those substitutions by default. Nice catch!

               

              As for the actual problem, clicking "More Options" simply does nothing other than freeze an orange highlight around the border of the button. Clicking is still enabled (I can keep clicking the button, showing "pressed" states, but nothing happens). The floating window doesn't invoke. I've carefully sleuthed around for it in the event it was hiding somewhere, but it simply doesn't appear. Hitting escape will exit the Footage Interpretation dialog box (returning to the active project window). This happens on multiple EXR sequences, and still images alike.

              • 4. Re: Open EXR Channel Caching Options Broken?
                fnordware Level 3

                Steve, I didn't see an email from you.

                 

                Anyway, it looks like the problem is that you have smart quotes in your preferences file instead of the regular dumb quotes. They were probably put there by the text editor you used (Microsoft Word?). After Effects seems to be complaining about that.

                 

                Did you get the window before you edited the preferences file?

                • 5. Re: Open EXR Channel Caching Options Broken?
                  steve patterson Level 1

                  Hey Brendan!

                   

                  Sorry that you never got the email. I did get the preferences file edited with vanilla quotes, and that seems to be working well, but I've been unable to get the floating window to work to date.

                   

                  Thanks,

                  -Steve

                  • 6. Re: Open EXR Channel Caching Options Broken?
                    fnordware Level 3

                    So you're getting the channel caching options dialog now, right?

                     

                    With the latest beta, using displayWindow is the default, although it may be set differently if you've been using previous betas. What do your OpenEXR preferences look like now?

                    • 7. Re: Open EXR Channel Caching Options Broken?
                      steve patterson Level 1

                      Thanks for the quick feedback!

                       

                      Negative, though, I'm not getting the dialog box. When I click on "More Options", no box appears. The orange highlight around the "More Options" buttons stays lighted, but no pop-up invokes. Using the latest installer from your site.

                       

                      Best,

                      -Steve

                      • 8. Re: Open EXR Channel Caching Options Broken?
                        steve patterson Level 1

                        Here's what I'm seeing:

                         

                        • 9. Re: Open EXR Channel Caching Options Broken?
                          fnordware Level 3

                          Hmm, I have not been able to duplicate. I've got AE 12.2.1 running in Mavericks 10.9.2. Clicking the More Options button brings up the dialog as expected. Is that your only monitor?

                           

                          Note that AE CC ships with an OpenEXR plug-in that has the same dialog and has been well-tested by Adobe. I tried with both the included plug-in and the current ProEXR 1.9 beta (after disabling the originals, of course), and both worked. It's possible that I broke something in the 1.9 beta, but unlikely.

                           

                          Maybe try moving your Preferences file to the desktop and have AE make a new one? If that brings the dialog back, send me that preferences file.

                          • 10. Re: Open EXR Channel Caching Options Broken?
                            steve patterson Level 1

                            Thanks so much for your continued support, Brendan. I know you are busy.

                             

                            I do have another monitor connected via thunderbolt, and I get the same results when I have it disconnected (post restart). Also, I get the same results if I try launching AE with clean prefs. It's very odd. My machine specs are: iMac 3.2ghz, i5, 24 GB RAM. Same OS and AE versions as in your test.

                             

                            Again, many thanks for your efforts. I'm apparently in the vast minority (possibly the only one) seeing this issue, but it shows your extreme loyalty to your customers for taking such an active role in supporting us.

                            • 11. Re: Open EXR Channel Caching Options Broken?
                              fnordware Level 3

                              Perplexing. Do you have the same problem with the plug-ins that ship with AE? If you deleted them, you can get the 1.8 release from the regular ProEXR page.

                               

                              BTW, with 1.9 you should have more OpenEXR preference items than I see in the screenshot you posted. One you can use as a work-around is called "Auto Cache Threshold", which defaults to 0. If you set it to a non-zero value like 8, the Cache Channels option will be turned on for you automatically if an EXR file you import has 8 channels or more. If you set it to 1, then all EXR files will have their channels cached.

                              • 12. Re: Open EXR Channel Caching Options Broken?
                                steve patterson Level 1

                                Thanks again for your tireless help, Brendan.

                                 

                                I ended up deleting all instances of the EXR plug-ins, and re-installing them (beta), and everything seems to be working properly now. Perhaps I had a conflict between versions in the format/effects folders?

                                 

                                In any case, thanks very much for everything. I did end up setting the "Auto Cache Threshold" to 1 in order to have all imported EXR files cache their channels. I did examine the dialog box after setting that preference, and it seems that the checkbox is enabled, but the cache value is set to "0". Does this mean that my manually entered settings in the preferences text file are overriding what's in the dialog box? For example, if I have "Auto Cache Threshold" set to 1, are all channels being cached? Does it make moot the "Channel Caches Number" setting? I do have the  "Channel Caches Number" currently set to 30, as that is more than enough to cover my usual EXR output from Maya. Thanks for your support!

                                 

                                Best,

                                -Steve

                                • 13. Re: Open EXR Channel Caching Options Broken?
                                  fnordware Level 3

                                  Glad to hear it you got the dialog back!

                                   

                                  The Channel Caches Number is the number of files that will be cached at a time. Each file will have all of its channels cached, no matter how many there are.

                                   

                                  If the menu says 0, that's because you entered a number bigger than what is offered in the menu. But then if you click OK, the number really will be set to 0, which will turn channel caching off application-wide. This is a hazard of editing the preferences file manually.

                                   

                                  The default for that setting is 3. The only reason you'd need more than 3 is if you had more than 3 separate multi-channel EXR sequences being loaded into one comp simultaneously.

                                  • 14. Re: Open EXR Channel Caching Options Broken?
                                    steve patterson Level 1

                                    Got it, thanks!

                                     

                                    Do you think the naming is a bit misleading in the dialog box? Just a suggestion, but perhaps on the next iteration/release you can modify the diction in the dialog box to reflect the concept that the Channel Caches refers to files and not total channels?

                                     

                                    You've been unbelievably helpful and prompt as always, Brendan. Thanks so much, and I hope this thread can be useful to anyone else who may experience similar circumstances in the future!

                                     

                                    Best,

                                    -Steve

                                    • 15. Re: Open EXR Channel Caching Options Broken?
                                      steve patterson Level 1

                                      Also, FWIW, I see a dramatic read performance increase with Channel Caching (over a NFS mounted network share). Thank you!