8 Replies Latest reply on Nov 13, 2014 12:40 PM by belindo

    After Effects CC audio mapping problems

    petter_re Level 1

      Whenever I start After Effects it seems like it takes over control of my system audio output settings.

      For instance if I am listening to a song on iTunes and then start After Effects, I will only hear iTunes when AE is active from then on. Audio preview and scrubbing in After Effects works well, and all other audio works as they should but only when using After Effects. If I switch back to iTunes it goes silent. This goes for all other audio on my computer.

       

      To get the audio back I need to go into system preferences and swich back and fourth in my settings. But if I then go into After Effects again the problems are back. It feels like After Effects hijacks my system audio setting when it is started. Is there a way to prevent this from happening?

       

      I am running After Effects CC 12.2.1.5 on OSX Mavericks.

        • 1. Re: After Effects CC audio mapping problems
          Szalam Adobe Community Professional & MVP

          Could we see a screenshot of your audio preferences in AE?

          • 2. Re: After Effects CC audio mapping problems
            Pixeldude

            got the exact same issue and have no idea what's going on...

             

            A restart fixed the problem for a while but then i started a render from AE and the audio was killed from Spotify. Audio works only when im in AE if i "cmd+tab" out in Safari or spotify the audio is killed. Makes no sense.

            • 3. Re: After Effects CC audio mapping problems
              petter_re Level 1

              I think I solved it.

               

              It seems that After Effects (and all other CC applications that use audio) generates some settings in the Audio and MIDI device setup found under Applications>Utilities.

              I think they are ways to make specific audio setups for these applications. You can probably edit these settings to match the system setup, but I just deleted them and now everything works fine.

              • 4. Re: After Effects CC audio mapping problems
                ericsbowman Level 1

                This has been bugging me like crazy. Thanks so much for this. Seems to work on my end at least.

                 

                Just to clarify for others, you should launch the Audio Midi Setup app and you'll likely see a list to the left with After Effects and other apps. I had AE and Premiere listed. I simply clicked on the minus sign to delete them and everything started working perfectly. Still had audio in AE, Spotify, and could Cmd+tab to whatever.

                • 5. Re: After Effects CC audio mapping problems
                  ericsbowman Level 1

                  Well I take it back now. I guess I got lucky with that. It worked once and never again. I've restarted AE, restarted OS X, deleted the AE device listed in Audio Midi Setup, tried everything I can think of. It's funny though, it works for me up until the moment I press the period key on the numpad to preview the audio, or if I hold down Cmd and drag on the timeline. I get a beachball for a few seconds and then the audio plays fine in AE, and Spotify goes back to not playing unless the AE window is active. If I use Safari, Chrome or any other app, Spotify is no longer audible

                  • 6. Re: After Effects CC audio mapping problems
                    Metalspray

                    Hey there, I'm having the exact same problem (Mavericks 10.9.1, AE 12.1).

                    I use an H/K AVR 165 with 5.1 as my default audio device (HDMI). Are you using HDMI as well? Because every other connection works (cinemadisplay speakers, optical), only when I have HDMI as my default the remapping occurs.

                    Waring: don't try to pick After Effects (12) or Premiere (7) as default in the sound-options in osx preferences (not the MIDI device, the aactual sound output in the preferences), I tried this yesterday and at first I thought it worked (I picked Premiere, I was just testing and curious) but as soon as I started Premiere, the whole system crashed and i needed several safe boots to get my Mac working again (it froze right after the login).

                    • 7. Re: After Effects CC audio mapping problems
                      Szalam Adobe Community Professional & MVP

                      Metalspray wrote:

                       

                      Hey there, I'm having the exact same problem (Mavericks 10.9.1, AE 12.1).

                      Just for the record, if you're running AE 12.1, you're missing bug fix updates. AE should be 12.2.1.5 (or version 13, if you really want to be current).

                      • 8. Re: After Effects CC audio mapping problems
                        belindo

                        Thanks Peter!!!!!!! I just open an Adobe account just to say THANKS PETER!!!