1 Reply Latest reply on Apr 29, 2014 11:09 AM by A.T. Romano

    I can't install Premiere Elements {new purchase} because of "Error 2350. 'FDI Server Error.'"

    Locoba

      I can't install Premiere Elements {new purchase} because of "Error 2350. 'FDI Server Error.'" I cannot "ignore"  I can only abort. Adobe says that my purchase is not supported even though it's new. Help anyone?