4 Replies Latest reply on May 8, 2014 11:57 PM by Starter45

    Can't save file: file in use

    Starter45

      I'm experience a vital problem in my workflow editting pictures in Photoshop CS5. I'm unsure what causes this problem since it worked fine all the time untill 2 weeks ago. What's my problem:

       

      I have a system (win7 64 bit) with 3 drives: C:/, D;/ and E:/

      I'm using C for operating system and vital programms, like Adobe

      I'm using D for data, like all the RAW images and editted images

      I'm using E for try-out programs, downloaded unimportant stuff etc, kind of a playfield.

       

      Opening Bridge: selecting a RAW file from D, opening in RAW converter, then from converter towards Photoshop

      I edit to my liking and save the file

      When hitting the 99% of saving operation i get an error, mentioning that the file can't be saved since "it's not closed or another programm uses the file"  As mentioned try to save on D. I've tried in any format; PS, tiff, jpeg etc.

       

      I guarantee there is 0 programm open at that time, but just to be sure; i close Bridge what gives me no solution. restarting PS or even the whole system (with unsaved file!!) does not change anything.

       

      To my releaf i found out that, when saving towards C: everything go's smooth and i'm able to save! Then, cutting and pasting on D go's like a charm.

       

      In all: what could cause this 'false' error problem?

       

      Workflow is now over-complicated, but at least i can save files.

       

      Help appreciated!

        • 1. Re: Can't save file: file in use
          Noel Carboni Level 8

          Have you looked in your Windows Event Logs (specifically, the System log) to see if you're seeing any disk errors?

           

          -Noel

          • 2. Re: Can't save file: file in use
            boo radley 2013 Level 3

            I have this same problem all the time, and have never figured it out.

             

            I save the first time, it gives me the error.

             

            I try saving it again, and this time it works. Every time, (whenever this error happens), it takes two attempts to save it. But it will always work on the second try.

            • 3. Re: Can't save file: file in use
              Noel Carboni Level 8

              I don't think it's a given.  I've never seen it happen to my knowledge.

               

              What anti-malware solution do you have?  And do you have Windows Indexing enabled?

               

              -Noel

              • 4. Re: Can't save file: file in use
                Starter45 Level 1

                Thx Noel Carboni for your time and effort to assist.

                 

                Indeed i have not looked at my log. I will do so.

                However; with great reserves; i think (or better hope) i have managed to solve the problem with help of a Senior systemadvisor i met yesterday.

                 

                In preferences i changed the active operating Drive (hopefully correct translation from dutch version; Werkschijf) from C:\ towards E:\ (pls keep in mind, all drives are the same type HDD 7200 rpm drives)

                I changed memory in use for PS towards 70% and is now 20.000Mb

                 

                I then editted and saved 4 (large) files with succes on my D:\ drive without problems.

                 

                Hopefully it stays this way

                 

                BTW: i must admit Noel, that aroound the arising of my problem i could have installed MBAM antimalware, I think indeed i did so arround that time. But as you can understand, if the solution i have now persists i'm reluctant to try that out. But when the problem returns i will for sure keep this in mind.

                 

                Thx for your help.

                 

                @ Boo Radley; your problem differs from mine as far as i can see in your post. Nevertheless maybe my solution so far can work for you also or at least set you on the right track. Good luck.