1 Reply Latest reply on May 8, 2014 7:07 AM by Noel Carboni

    I'm running CS4 and use a Canon T3i to shoot RAW. Which camera raw patch do I need?

    hsebresos

      I'm running CS4 and use a Canon T3i to shoot RAW. Which camera raw patch do I need? I get his error when trying to install the latest patch: "Adobe Application Manager is needed to resolve this problem, however it is missing or damaged. Download a new copy of Adobe Application Manager or install this product again."

        • 1. Re: I'm running CS4 and use a Canon T3i to shoot RAW. Which camera raw patch do I need?
          Noel Carboni Level 8

          If the camera is newer than the last version of Camera Raw that was released for an older version of Photoshop, you won't be able to get direct, convenient "open file" support for the raw files.

           

          You can check per these links:

           

          Minimum Camera Raw version required for a particular camera:

          Camera Raw plug-in | Supported cameras

           

          Camera Raw versions available for update with various Photoshop releases:

          Camera Raw-compatible Adobe applications

           

          Just glancing at those links, Photoshop CS4 can update to only as far as Camera Raw 5.7.  Unfortunately, the minimum required version to work with your T3i is Camera Raw 6.4.

           

          Your fallback position will be to either convert your raw files to DNG format with the latest free DNG converter release, or get a newer version of Photoshop.  The later has an advantage in that there have been substantial improvements to Camera Raw in recent releases.

           

          -Noel