21 Replies Latest reply on Aug 4, 2014 9:37 AM by dharmk

    Edge Animate Publish Failed

    smeedee Level 3

      Hi All,

       

      I've been using the trial of EA to learn the new product for use as an alternative to Flash/SwishMax.

       

      I have been developing a project over the last two weeks and today, after a lot of work, publish failed

      with the error

      'An error has occurred. Please save your work and re-start edge animate.'

       

      I did. It didn't.

       

      I have tried saving to another file but to no avail.

       

      Further, if I just try to save the file after opening, the same error occurs.

       

      Does anyone have any ideas? I don't want to lose all this time.

       

      Regards

      David Hatton

        • 1. Re: Edge Animate Publish Failed
          heathrowe Most Valuable Participant

          Did you publish at any time, prior to this attempt and was it successful?

           

          Are you publishing to your hard drive or somewhere else?

           

          As a simple test, aside from the project that is causing the issue, open Edge Animate, create a very simple project - nothing fancy, just a text block and a div box with a simple timeline animation (fade in-out, for example). Save it to a folder on your desktop - then Publish it. How did this go?

           

          Darrell

          • 2. Re: Edge Animate Publish Failed
            smeedee Level 3

            Hi Heathrowe,

             

            Thanks for replying.

             

            Yes I have published several times before with no issues.

             

            When I load the file into AE and try to edit I find that all the actions for my symbols have disappeared. Very strange. I have a feeling that a file is corrupted. Hey ho.

             

            As for publishing a different project, no problems.

             

             

             

            David

            • 3. Re: Edge Animate Publish Failed
              heathrowe Most Valuable Participant

              Ya something pertaining to this particular file, it seems.

               

              One recommendation.

              Copy this current project, files and folders, to another location - as a simple backup.

               

              Open Edge Animate, go to File > Open and navigate to .html file, (not the .an file).
              Once opened, File > Save to another folder location. Then File > Publish.

              See what happens.

               

              If it still persists, perhaps post a zip link to all the project files for others to see what is going on.

              Darrell

              1 person found this helpful
              • 4. Re: Edge Animate Publish Failed
                smeedee Level 3

                Thanks for your help Darell. I tried that but no luck. I decided to delete it and start again. At least I can do it faster now

                 

                I wonder if there is a log file somewhere for when it crashes?

                 

                Regards

                David

                • 5. Re: Edge Animate Publish Failed
                  CPBTenner Level 1

                  I am having the same problem. It happened with 2 different files, one very simple, the other very complex and time consuming.  Here is a link to the simple version if you want to try and troubleshoot it.  I am hoping to find a solution so I do not have to rebuild the 3+ week long project I have been working on.

                   

                  www.capitalpress.biz/html5ads/youtube/testEmbeddingYoutube.zip

                   

                  Thanks,

                   

                  Brandon

                  • 6. Re: Edge Animate Publish Failed
                    CPBTenner Level 1

                    ****UPDATE****

                     

                    I decided to delete individual symbols and then try and save/publish to see if I could find the problem area.  After deleting my video/youtube symbol the file saved and published.  I completely deleted the symbol from my library and rebuilt it and everything worked!

                     

                    I still do not know why the error occurred but that saved me from having to completely rebuild the whole project.

                     

                    Brandon

                    • 7. Re: Edge Animate Publish Failed
                      dharmk Adobe Employee

                      Hi Brandon,

                       

                      I tried to open and publish the file that you shared @ www.capitalpress.biz/html5ads/youtube/testEmbeddingYoutube.zip and it works fine locally. Do you have any other copy of the project which had publishing issues?

                      We would like to investigate the issue further but need any sample to reproduce the issue locally.

                       

                      Regards,

                      Dharmendra

                      • 8. Re: Edge Animate Publish Failed
                        CPBTenner Level 1

                        Dharmendra,

                         

                        That is strange that you cannot recreate the issue. When I download the file and open it I still get the same publish error.  I also updated my version of Edge Animate to CC 2014 thinking that would solve the problem but it did not.

                         

                        One other thing I noticed was that after I tried to publish the file it would not preview in a browser, I got the following error and message.  Hopefully this helps?

                         

                        Brandon

                        • 9. Re: Edge Animate Publish Failed
                          resdesign Adobe Community Professional & MVP

                          Maybe try to publish in a different location.

                          • 10. Re: Edge Animate Publish Failed
                            CPBTenner Level 1

                            That didn’t work either, tried publishing to my desktop and got the same error.  When I looked in the folder it only had a html file in it.  Would it be helpful to include that?

                             

                            Brandon

                            • 11. Re: Edge Animate Publish Failed
                              dharmk Adobe Employee

                              hmm, I will try to reproduce this again on some other machine otherwise I will connect to you later sometime directly to collect more information on the issue. If you can attach a screenshot, video of the operation then that may be useful.

                               

                              -Dharmendra

                              • 12. Re: Edge Animate Publish Failed
                                heathrowe Most Valuable Participant

                                Brandon you don't mention 'What' the error says.

                                I tried your sample file and it worked fine.

                                 

                                Darrell

                                • 13. Re: Edge Animate Publish Failed
                                  CPBTenner Level 1

                                  Darrell,

                                   

                                  Attached are screen shots of the error messages I receive when I try and publish the file as well as when I try to preview the file in a browser after the message.

                                   

                                  Brandon

                                   

                                  Screen Shot 2014-06-25 at 7.50.56 AM.png

                                  Screen Shot 2014-06-25 at 8.34.51 AM.png

                                  • 14. Re: Edge Animate Publish Failed
                                    CPBTenner Level 1

                                    Dharmendra,

                                     

                                    The problem is occurring on my work computer and I do not have time to troubleshoot it today, (It is our deadline day).  I am not sure how to do a desktop video to show the operation, otherwise I would be happy to include it so that you could help solve the mystery.

                                     

                                    Brandon

                                    • 15. Re: Edge Animate Publish Failed
                                      heathrowe Most Valuable Participant

                                      Ah.

                                       

                                      I do get one message now - see attached. I have a suspicion it is writing incorrect file paths.

                                      message.jpg

                                      I also have seen the preview error message as well, with some of my own files, and have this reported.

                                       

                                      Darrell

                                      • 16. Re: Edge Animate Publish Failed
                                        CPBTenner Level 1

                                        Thanks for pointing this out, looking at the screenshot of my error it appears to be adding an additional slash between web and TestEmbeddingYoutube.html. I believe you are correct in your suspicion that the program is writing incorrect file paths.

                                         

                                        Screen Shot 2014-06-25 at 8.51.43 AM.png

                                        • 17. Re: Edge Animate Publish Failed
                                          dharmk Adobe Employee

                                          Hi Brandon,

                                           

                                          I am able to reproduce it now after I did a save as, even with the version which was saved at the original location. I am looking into the issue, will post the udpate soon. Don't worry about the video, you can continue with your work. I am assuming you are unblocked right now for the deadline based on your earlier update, but we will still try to see if there is anything useful info we can provide quickly.

                                           

                                          Regards,

                                          Dharmendra

                                          • 18. Re: Edge Animate Publish Failed
                                            dharmk Adobe Employee

                                            Hi Brandon,

                                             

                                            Right now you can use a workaround if you encounter the issue again. Open the composition afresh, double click on the video symbol instance to go into its edit mode, come back to stage. After that, you should not have any publish issues in that session till the time you close the file again. We will post an update again on this issue soon.

                                             

                                            Regards,

                                            Dharmendra

                                            • 19. Re: Edge Animate Publish Failed
                                              CPBTenner Level 1

                                              Thank you.  I will not be working on the project until tomorrow but this will help me move forward with it.  I look forward to your update soon.

                                               

                                              Brandon

                                              • 20. Re: Edge Animate Publish Failed
                                                dharmk Adobe Employee

                                                Hi Brandon,

                                                 

                                                We figured out that it is a bug in Edge Animate. If you have a composition which contains an empty symbol and you have the setting "Set the Publish Content As Static HTML" on in the publish settings, then animate throws this error on publishing. It will happen every time you open the file and publish. We are working on the fix, thanks for reporting it.

                                                 

                                                Till the time the bug is fixed, the following workaround can be used:

                                                 

                                                - Create any element inside the empty symbol, mark it as hidden and save the composition (Basically make sure that you don't have any empty symbol).

                                                 

                                                Sorry about the inconvenience.

                                                 

                                                Regards,

                                                Dharmendra

                                                • 21. Re: Edge Animate Publish Failed
                                                  dharmk Adobe Employee

                                                  Hi All,

                                                   

                                                  The issue with the empty symbol's have been fixed and we have posted a new update for Edge Animate. More details @ Edge Animate CC 2014 Update (2014.0.1) live now

                                                   

                                                  Regards,

                                                  Dharmendra