0 Replies Latest reply on May 12, 2014 3:52 PM by billklatt

    I installed Digital Editions on mac OS X 10.6.8.  Web site says it should work with 10.6 and later.  When i try to start it, it says it won't work on this computer, needs 10.7.  Now what?

    billklatt

      I installed Digital Editions on mac OS X 10.6.8.  Web site says it should work with 10.6 and later.  When i try to start it, it says it won't work on this computer, needs 10.7.  Now what?