6 Replies Latest reply on May 22, 2014 9:55 AM by Almyria

    Javascript not running

    Almyria

      Hi there! I'm a university lecturer whose just started using a new onscreen marking program from my university that allows us to mark student PDFs with an Adobe plug-in. Trouble is that I can't get the plug-in to run (or even detect it in Adobe). It should create several additional boxes on the quick tool bar (a tick, cross, calculator, etc.) but these don't appear. The marking plug-in installs in Adobe's "JavaScript" folder, and so that is why I'm posting the question here. According to the tech guys at my university the problem is because I'm using Acrobat 11 but I'm running Acrobat X and since they don't have any experience with my Windows 8 OS either, I don't know what else to do!!! I have reinstalled both Acrobat and the marking plug-in to no effect. After clicking the "Customize Quick Tools" icon the marking tool plug-in should appear on the list of possible tools to add but it doesn't. I'm also running the latest update of Java as well if that helps... If anyone has any ideas I'd be really grateful.

        • 1. Re: Javascript not running
          Test Screen Name Most Valuable Participant

          Some tips

          1. Post the exact folder you use for the .js file, it may be relevant

          2. Check the JavaScript console (Ctrl+J) for errors

          3. Post the exact revision (e.g. 10.1.2.3) and product (e.g. Acrobat Pro, Acrobat Standard, Adobe Reader) you are using.

           

          By the way, Java is nothing to do with JavaScript

          • 2. Re: Javascript not running
            Almyria Level 1

            Acrobat Pro 10.0.0 - a fresh reinstall.

            I'm using an automated installation disk from my IT dept. It puts acrobat in what looks like a pretty standard place under Programs Files (x86)/Adobe/Acrobat 10.0 and seems to install the script under Adobe/Acrobat 10.0/Acrobat/Javascripts. I wouldn't know how to check the script for errors...

            • 3. Re: Javascript not running
              Almyria Level 1


              Just wanted to add that the marking plugin seems to work just fine with Acrobat x when in the Windows 7 environment - I have a colleague using it under those circumstances. So can it maybe be a problem that the plugin has working with Win 8?

              • 4. Re: Javascript not running
                Test Screen Name Most Valuable Participant

                Don't know of a Windows 8 issue.


                Do Ctrl+J, a window should open. It might have error messages in it. If in doubt, copy/paste it all.

                • 5. Re: Javascript not running
                  Almyria Level 1

                  Ok so ran acrobat and did Ctrl+J. Got this:

                   

                  TypeError: aNewDoc is undefined

                  155:Folder-Level:App:config.jsAcrobat EScript Built-in Functions Version 10.0

                  Acrobat SOAP 10.0

                   

                  When I do the same thing on my colleague's pc (the one that runs the plugin successfully) I get this:

                   

                  GeneralError: Operation failed.

                  Doc.directXFARender:306:Folder-Level:App:config.js

                  Missing Mesh Restriction

                  Acrobat EScript Built-in Functions Version 10.0

                  Acrobat SOAP 10.0

                  • 6. Re: Javascript not running
                    Almyria Level 1

                    Thanks for all the help! A very simple, low tech solution seems to have sorted out the problem of the plug-in not loading - I uninstalled the plug-in, restarted the laptop, and then reinstalled the plug-in, and for some reason now it loads and seems to be running perfectly in Acrobat! If anyone can explain why that would be great!?