2 Replies Latest reply on May 21, 2014 7:15 AM by userCold9

    CF 9 admin database connection to SQL Server 2008

    userCold9 Level 1

      Hi,

       

      I am trying to get the Cold Fusion 9 Administration database connection to communicate to the database server.

      I have created an account on the SQL Server 2008 and used the account in the Cold Fusion 9 Administration database connection.

      When I verify the connection, the following message appears:

       

      Connection verification failed for data source: BUS_ULTC_Dev
      java.sql.SQLNonTransientConnectionException: [Macromedia][SQLServer JDBC Driver][SQLServer]Cannot open database "BUS_ULTC_Dev"

      requested by the login. The login failed.
      The root cause was that: java.sql.SQLNonTransientConnectionException: [Macromedia][SQLServer JDBC Driver][SQLServer]Cannot open

      database "BUS_ULTC_Dev" requested by the login. The login failed.

       

       

       

      Thanks,

       

      Mike

        • 1. Re: CF 9 admin database connection to SQL Server 2008
          REEDPOWELL

          Can you give us a little more detail on the "account" that you have created on the SQL Server 2008 system.  Is it a SQL login or a Windows domain login?  Are you certain that when creating the login in SQL that you then gave it permission to access the specific database that you are using on the CF Datasource screen?  If you are trying to use a Windows domain login for the CF datasource access, I believe that the only way to make that happen is to create the SQL Login for the same Windows domain account that the CF service is running under.  When you do that (use the Windows domain login), then you leave the username/password boxes blank on the CF Admin screen.

           

          hth

          reed

          • 2. Re: CF 9 admin database connection to SQL Server 2008
            userCold9 Level 1

            Hi,

             

            The default database setting is pointing to the database.

             

            I noticed that the selection in the User Mapping that the database was not selected and the database role was not selected.

            I selected the database and selected db_owner. Now, when verify the connection, the status comes back OK.

             

             

             

             

            Thanks,

             

            Mike