2 Replies Latest reply on Jul 3, 2015 9:45 AM by rastaroth

    AIR 4 SDK and asdoc

    DanelKirch Level 1

      Am loosing just too much time to figure out how the hell to get the AIR 4 sdk asdoc to work.

       

      The lack of documentation, instructions from Adobe is getting overwhelming... This is just unbelivable how a company can release a product without any documentation or such.

      Even if there are solutions, example and such, they always are spread out on some blogs... but not in this case, like everyone is holding information in hostage.

       

      So, now to my freggin question, how to set up the ASDOC on mac in Flash builder !?!?!?!?!?!?!?!?

       

      first when pointing external tool to asdoc, im getting error:

      usage: dirname path

      usage: dirname path

      Error: Unable to access jarfile /../lib/legacy/asdoc.jar

       

      Then i  change the patch in asdoc file to a absolute one... and im getting:

      usage: dirname path

      usage: dirname path

      Error: This Java instance does not support a 32-bit JVM.

      Please install the desired version.

       

      Seriously, 32bit on mac, what kind of default is that ? ARGHHHH

       

      then i change the desired version, 64 and now this....

      usage: dirname path

      usage: dirname path

      Adobe ASDoc

      Version 4.6.0 build 23201

      Copyright (c) 2004-2011 Adobe Systems, Inc. Med ensamr?tt.

       

      defaults: Error: cannot open "/../frameworks/flex-config.xml"

       

      this is just unbelievable. Why cant there be some decent instructions  provided by the provider which explains what is needed.

        • 1. Re: AIR 4 SDK and asdoc
          DanelKirch Level 1

          So, i found a solution which does work for now, still there should be instructions available officially from Adobe, instead of letting developers to spend hours, days or what ever on finding solutions...

           

          I guess there can be better solution but i did what i could from my little experience with flash builder and executables...

           

          in the asdoc file i commented out the scripthome, and added static variable instead, changes are underlined:

          SCRIPT_HOME="/Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK/bin/"

          if [ "x${FALCON_HOME}" = "x" ]

          then

              #SCRIPT_HOME=`dirname $0`

              FALCON_HOME=${SCRIPT_HOME}/..

          else

              echo Using Falcon codebase: $FALCON_HOME

          fi

           

           

          if [ "x${FLEX_HOME}" = "x" ]

          then

              #SCRIPT_HOME=`dirname $0`

              FLEX_HOME=${SCRIPT_HOME}/..

          else

              echo Using Flex SDK: $FLEX_HOME

          fi

          That solved the flex-config.xml issue.

           

          Then when i ran the external tool again, i got error on not finding locale sv_SE,

          so in AIRSDK/frameworks/locale i had no sv_SE, solution that worked was to make a copy of en_US folder and rename it to sv_SE.

           

          And since im trying to asdoc AIR, the ext tool should of cource have external libs added as well in arguments field:

          -external-library-path="/Applications/Adobe Flash Builder 4.7/eclipse/plugins/com.adobe.flash.compiler_4.7.0.349722/AIRSDK/frameworks/libs/air/airg lobal.swc"

           

          Hope this helps others in someway.

          • 2. Re: AIR 4 SDK and asdoc
            rastaroth

            This worked for me:

             

            I commented these lines on the bin/asdoc file

             

            # if [ "$isOSX" != "" -a "$HOSTTYPE" = "x86_64" -a "$check64" != "" ]; then
            # D32='-d32'
            # fi

             

            I found the answer here:

            actionscript 3 - MXMLC in Flex SDK 4.5 doesn't work on Mac OS 10.8 - Stack Overflow