1 Reply Latest reply on May 10, 2007 1:49 PM by MaKuMo

    Controllo winsock vsXMLSocket

    MaKuMo
      Salve a tutti!il mio problema è il seguente:
      Ho realizzato un server in visual basic 5 che utilizza il protocollo TCP/IP del metodo winsock.
      Il client ( in flash ) si collega a questo server utilizzando la classe XMLSocket.
      La connessione viene stabilita,riesco ad inviare i dati dal flash al server ma non riesco ad inviare i dati dal server al client ( i dati vengono inviati perchè ho fatto una prova creando un client in visual basic ).


      Questo è il codice che utilizzo:
      Socket=new XMLSocket();
      Socket.connect("localhost",2000);
      Socket.onData=function(msg:String):Void{
      trace("sono arrivati i dati");};


      I dati che invio hanno il seguente formato:
      "comando1◄comando2◄comandox"
      Il ◄ è un separatore.

      Qualcuno mi può aiutare? Sto impazzendo...
      Saluti da Samuel e Simona.
        • 1. Re: Controllo winsock vsXMLSocket
          MaKuMo Level 1
          I'm sorry.I'll write in english this time :D
          Hi everyone!
          I've got this problem:
          I've done a server coded in visual basic 5.0 that uses TCP/IP protocol with winsock method.
          The client (done with flash) connects to this server using XMLSocket class.
          I can connect to the server with this client, i can send data from flash to visual basic but i can't send data from visual basic to flash!Data is sent from the server....i'm sure of this the because i've done a little client in visual basic and receivers data.
          This is part of the code in actionscript (where i think is the mistake):
          Socket=new XMLSocket();
          Socket.connect("localhost",2000);
          Socket.onData=function(msg:String):Void{
          trace("data has arrived");};

          Data sent from the server have this format:
          "command1◄command2◄commandx"
          The ◄ char is just a separator i use to elaborate the string.Even with a 0 char at the end,client won't the receive anything....
          I'm freaking out!Someone help me please!!!