0 Replies Latest reply on Jun 2, 2014 12:38 PM by Sly Raskal

    Flash Builder 4.6 crashes during startup [RESOLVED]

    Sly Raskal Level 1

      I am documenting my troubles with Flash Builder 4.6 here for others in the event they come across the issue I experienced.  There is nothing that needs resolving at this time so you may ignore this post.

       

      Sometime after April 21st of this year my installation of Flash Buiilder 4.6 on my machine running OS X 10.9.2, had stopped working.  I was unable to start up Flash Builder 4.6 without it simply crashing immediately after the words "Loading Workbench" Appeared on the splash image.

       

      I had tried removing my existing workspace and allowing the application to rebuild a new one which did not work. I also checked the Apple Console App for any errors and the following errors were being reported every time the application crashed shortly after I attempted to start the application:

       

      5/27/14 10:08:39.032 AM Adobe Flash Builder 4.6[2547]: Unrecognized Java VM option ignored: -Xdock:name=Flash Builder

      5/27/14 10:08:39.032 AM Adobe Flash Builder 4.6[2547]: Unrecognized Java VM option ignored: -Xdock:icon=../Resources/fb_app.icns

      5/27/14 10:08:39.032 AM Adobe Flash Builder 4.6[2547]: Unrecognized Java VM option ignored: -XstartOnFirstThread

       

      I did a lot of searching via Google and the Adobe forums, but could find no references to anyone else that had experienced the same problem with this version 4.6 of Flash Builder.  So reluctantly, I reinstalled Flash Builder 4.6 and sure enough, everything worked again.  Something must have been corrupted in my installation even though I had made no changes to my installation during the time period in question.  I wanted to share this information with the community in the event that any of you come across this strange error.

       

      Cheers.