11 Replies Latest reply on Mar 26, 2015 10:01 AM by starrd

    Mapped topic names missing in Map ID dialog

    starrd

      Using Robohelp 10/FM11

       

      We recently noticed that some mappings in the All Map IDs dialog appear unmapped, but actually work properly.  Specifically, the map ID is valid, but the topic name it's mapped to is not displayed in the dialog.  That column is blank.  The .h and .ali files appear to be fine.  What's more, I noticed when I created a single sourced project from FM to RH, the markers I created manually work, but the matching topics are similarly "blank" in the dialog even though they are present in the .ali and .h, and the links work fine.  The markers that RH creates for the individual chapter names actually do appear with topic titles, the markers i create to do not. Also, the topic properties only show the RH generated Map ID, not the one I created, but again the ones I created are in the adjunct files and seem to work.

       

      The reason I am posting is that editing .h and .ali to verify mappings are correct is not trivial. We should be able to verify the mappings in the GUI.  I would note that this did not seem to be an issue in RH9. I was able to generate the book and see that my IDs mapped across properly by examining them in the Map ID GUI.

       

      It is not clear to me what could have changed in RH10 to prevent the GUI from displaying the mappings but this seems like a defect. I wondered if anyone else had encountered it and come up with a solution.

       

      Here are some notes and a pic, from a small sample project, for reference:

       

      The vv_ tags come from the FM book as "HelpMarker" values

      conversions.png

       

      The MapID dialog looks like this...the book chapters are titled uc-foo.fm

      xxxx.png

       

      Here is an example of a topic that has the automatic "marker" for the chapter listed, but not my vv_licensing marker; see below that it does appear in the .ali file

      lic.png

       

       

      Map IDs are automatically being assigned for my HelpMarkers

       

      BSSCDefault.h:

      #define vv_streams_view    7

      #define vv_media_monitor    11

      #define vv_licensing    1

      #define vv_call_search_view    3

      #define vv_conversation_view    5

      #define vv_single_call_view    9

      #define uc-licensing    2

      #define uc-call-search    4

      #define uc-conversation-view    6

      #define uc-streams-view    8

      #define uc-single-call-view    10

      #define uc-media-monitor    12

       

      The URLs are correct for the HelpMarkers -- why aren't these in the MapID Dialog above?????

       

      Project.ali

      <?xml version="1.0" encoding="utf-8"?>

      <aliaslist version="1.0">

          <alias name="vv_single_call_view" link="uc-help\uc-single-call-view\uc-single-call-view.htm#CSH_1">

          </alias>

          <alias name="vv_call_search_view" link="uc-help\uc-call-search\uc-call-search.htm#CSH_1">

          </alias>

          <alias name="vv_conversation_view" link="uc-help\uc-conversation-view\uc-conversation-view.htm#CSH_1">

          </alias>

          <alias name="vv_streams_view" link="uc-help\uc-streams-view\uc-streams-view.htm#CSH_1">

          </alias>

          <alias name="uc-call-search" link="uc-help\uc-call-search\uc-call-search.htm">

          </alias>

         <alias name="vv_licensing" link="uc-help\uc-licensing\uc-licensing.htm#CSH_1"> <-- note that these HelpMarker IDs do not appear in Topic Properties, as illustrated in above screenshot

          </alias>

          <alias name="uc-conversation-view" link="uc-help\uc-conversation-view\uc-conversation-view.htm">

          </alias>

          <alias name="vv_media_monitor" link="uc-help\uc-media-monitor\uc-media-monitor.htm#CSH_1">

          </alias>

          <alias name="uc-licensing" link="uc-help\uc-licensing\uc-licensing.htm">

          </alias>

          <alias name="uc-streams-view" link="uc-help\uc-streams-view\uc-streams-view.htm">

          </alias>

          <alias name="uc-single-call-view" link="uc-help\uc-single-call-view\uc-single-call-view.htm">

          </alias>

          <alias name="uc-media-monitor" link="uc-help\uc-media-monitor\uc-media-monitor.htm">

          </alias>

      </aliaslist>

        • 1. Re: Mapped topic names missing in Map ID dialog
          Jeff_Coatsworth Adobe Community Professional & MVP

          Check your FM source to ensure that the vv_licensing marker text is being applied to the topic properly with the correct type of marker.

          • 2. Re: Mapped topic names missing in Map ID dialog
            starrd Level 1

            Hi Jeff:

             

            Thanks for replying.  Yes, they are. I know my post was a bit wordy, but I think I mentioned that the markers actually do function, they just don't show in the GUI.  Here is a screenshot of a ListofMarkers from the FM.  The thing that is distressful is that the associated topics are mapped but the topic name is not displayed in the MapID Dialog.

             

            nnnn.png

            • 3. Re: Mapped topic names missing in Map ID dialog
              Jeff_Coatsworth Adobe Community Professional & MVP

              So these all appear to be in some uc-help FM doc – when it gets split up, is there something different about the paragraph tags you’re using for pagination for this vs. the ones that seem to work?

              • 4. Re: Mapped topic names missing in Map ID dialog
                starrd Level 1

                The paragraph tags for pagination are not related to the issue, I don't think. It splits on H1 and Title and it does that properly.  I do not have it creating markers on either of those, just on the marker labeled: HelpMarker. The mapIDs with uc-foo are not used and not requested by me, i don't know why RH is making them, but assume it needs them for a purpose. They correspond with the filenames of the chapters in the book. Those do appear with topic names, but it's illogical for those to appear and not the topic names for the vv_ tags.

                • 5. Re: Mapped topic names missing in Map ID dialog
                  starrd Level 1

                  Argh.

                   

                  I did another test so i could show multiple help tags in one file -- which is common for this product, and did another force update. It looks like adding another tag and forcing update tickled RH to reload the topic list for the other Map IDs.  I swear I will send $100 to anyone who explains the logic to me of what it takes to get RH to do a real force update. It really seems that some magic combination updates some files but not others. For different issues, I've tried closing FM and RH and reopening and then forcing, and at times have had to remove and re-add the book. There must be some magic. Or perhaps "force update" is an erroneous term that needs more explanation.


                  At any rate, apparently I solved the current case by adding another ID. Inexplicable that it worked today and not yesterday.

                  • 6. Re: Mapped topic names missing in Map ID dialog
                    Jeff_Coatsworth Adobe Community Professional & MVP

                    LOL – yet another reason why I use Import & not Link with my FM to RH project ;>)

                    • 7. Re: Mapped topic names missing in Map ID dialog
                      starrd Level 1

                      Still wondering if anyone else has had this occur in their project.  I've since converted my project to be HTML only rather than linking to FM, but the issue is still present. I've checked BSSCDefault.h and superhelp_541.ali to ensure they do not have any weird characters and that they are consistent with each other.  To no avail. I still have blank entries for some records -- Seems to be unrelated to order of topic creation. Some very old records show no topic as well as newer ones. The mapping works, it is just not displayed in the dialog itself.

                       

                      :/

                      • 8. Re: Mapped topic names missing in Map ID dialog
                        Jeff_Coatsworth Adobe Community Professional & MVP

                        Yes, I get that effect in the Map ID screen if I’ve imported content from FM, saved the RH project and then retrieved it again later. The Topics only seem to display when the project is freshly imported; once you’ve closed RH and reopen the project again, they all disappear from the screen (but you’re correct, they all still function fine – it just makes editing/deleting them hard to figure out).

                        • 9. Re: Mapped topic names missing in Map ID dialog
                          starrd Level 1

                          Hi Jeff

                           

                          Thanks for answering.  The map IDs that are misbehaving are not all related to the files originally sourced from FM. The project has about 2700 topics, of which only a handful were converted from FM.  I wish there was an obvious way to determine how to make the map ID dialog show the data that it clearly "knows" is present.

                           

                           

                          • 10. Re: Mapped topic names missing in Map ID dialog
                            Peter Grainge Adobe Community Professional (Moderator)

                            Not sure if this will help. In Tools > Reports > Topic Properties there is an Options button. That allows you to select what you want to see and Map IDs is one option.

                             

                            I assume your check of the h and ali files was done via a text editor, the easy way of seeing what is in them.

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                             

                            @petergrainge

                            • 11. Re: Mapped topic names missing in Map ID dialog
                              starrd Level 1

                              Hi Peter:

                               

                              Nice to hear from you!

                               

                              The files are correct -- I've done analysis and all the data is there.  I did find one other data point that is beyond baffling tho. Other writers do see the data in the dialog (they copy the project locally after I've merged everyone's updates).  I am beginning to wonder if something is hinky with my environment.


                              I have 8GB of memory but otherwise our configs are pretty much the same.

                               

                              Another mystery.

                              D