5 Replies Latest reply on Jun 14, 2007 7:19 AM by AdbeUserRG520

    Disable "File on my computer"?

    botwood7
      Hi, I am trying to set up a new Contribute site and am in the process of customizing the menus and toolbars to suit our needs. I am wondering if there is any way to disable/remove the button "File on my computer" on the "Insert link" dialog. If anybody knows of a way to do this, any help would be greatly appreciated.
        • 1. Re: Disable "File on my computer"?
          ThinkInk Level 2
          I couldn't find a way to get it grayed out, but you can prevent users from uploading files by doing this:

          1. In the menu got Edit, Administer websites, choose your website
          2. Choose User en Roles
          3. Choose the role that you want to adjust en choose Edit Role settings
          4. In the Role Settings choose File Placement
          5. Check Reject Linked files and insert '0' at Max Filesize.

          grtz.
          Hayo
          • 2. Re: Disable "File on my computer"?
            botwood7 Level 1
            Thank you so much. That will work just fine.
            • 3. Re: Disable "File on my computer"?
              AdbeUserRG520 Level 1
              Hi,

              I was looking to do the same thing, and found the same solution when browsing through the various role settings. HOWEVER, I think I may have run into a bug, or at least I want to make sure I'm interpreting the option correctly. Namely, when I set the "max file size" to 0, this is supposed to effectively disable people from uploading NEW files to the web site (i.e. Link to "File from My Computer" option). But this should NOT prevent people from linking to existing files on the website, correct? For example, by using the Link --> Browse to Webpage --> Choose, and then selecting an existing, say PDF, file in the website structure...

              When I tested this at our environment, I had few people tell me that they received a message that they don't have permissions to do such and such action, when they tried to add links by using the "browse to webpage --> choose" option... But few other test cases worked fine...

              Bug? Anybody else experience this?
              • 4. Re: Disable "File on my computer"?
                ThinkInk Level 2
                The purpose of the setting is that you can limit the filesize of uploaded files. I don't know if Adobe meant to use this setting to block file-upload, but it works so anyway.
                I just use the setting this way so no files, except images, can be uploaded from the users computer to the server.
                But you should be able to connect to files on the server by using te Brows to webpage, Choose option when inserting a link.
                This works fine when I use it, so maybe there's really is a bug or there is a problem with the specific installations of Contribute or other program's with the users where is doesn't work properly?

                grtz.
                Hayo
                • 5. Re: Disable "File on my computer"?
                  AdbeUserRG520 Level 1
                  Actually, I would assume they meant it to be used in this way, because they have a note about it below that setting. It says something like "to completely disable file upload, enter 0 for file-size..."

                  The way our users edit web pages and upload files might have something to do with the problem we're seeing... Our users have access to the server shared drive, so they copy-paste files directly to the server THAT way (in order to place them in certain subfolders, which are always deep in the web site structure, so they have to do it manually). They would, then, edit a web page through Contribute, and insert a link to the file they added recently, by using Browse-Choose method).

                  But in my mind, there should be no issue with Contribute's own "file upload" mechanism, since it's being "bypassed", in a way... Yet somehow, it still complains, intermittently, mind you... which is why I'm leaning onto the "bug" idea... :-) Since I saw the problem, I turned off the file-size limit, and I haven't had time to play with it more... but I really ought to do some more testing...