2 Replies Latest reply on May 11, 2007 8:33 AM by hao_flex

    refreshFill Doesn't Work

    hao_flex
      In most cases, the DataServiceTransaction.refreshFill works fine. But now I have a special case, we try to push report data to client side. There are two differences:
      1: Because report data have no real database id, so we generate ids.. Initially, I generated random id as java Long. Flex gave me error like "getItem" method not implemented.. I changed it to generate id incrementally, it worked in some cases, but doesn't work for some other. The difference between the working ones and the not working ones are minimal. We am debugging this issue, I can see the server is sending "collection update" message to client, but the client never get a "collection update" event.

      2. The second specially thing is that the assembler fill method returns a list of Map objects. This might not be the cause of the problem because we it worked for some reports.

      I just wonder how FDS implements refreshFill...can anybody explain it. Does anybody have ideas why this weird problem occur?

      Thanks a lot in advanced.