1 Reply Latest reply on Jun 6, 2014 3:38 AM by pwillener

    What version of Adobe flash player should I install??

    sajuliem

      My browser is Safari. My OS IS Linux. I use a kindle and I'm trying to get the flash player to work! Which is the correct one to install??