4 Replies Latest reply on Jun 14, 2014 12:25 PM by jbowden

    Autoplay Sound Not working on Safari & Chrome Desktop

    Denn S

      But it is on Firefox both desktop and devices.

       

      Nothing tricky here. Just added a sound file, set to autoplay and loop. Open in Safari or Chrome on a mac and no autoplay. Open in Firefox on mac, PC or android devices and it plays just fine (Surprising for the android devices but maybe on the latest update they abandoned the stupidity of not autoplaying if on wifi, haven't tried on 4ge). The fact that it works on Firefox and not the others (current versions all) seems to indicate it isn't the setup. Are there any known gotchas? Ideas?

       

      Here is the page

        • 1. Re: Autoplay Sound Not working on Safari & Chrome Desktop
          Denn S Level 1

          OK, we added an explicit playback to the audio track and set it to play and now it works. But with only one audio track and the audio set to auto play and loop (top left control area) that seems like it should not be necessary. And that does not explain why it worked fine on Firefox and on firefox in devices.

          • 2. Re: Autoplay Sound Not working on Safari & Chrome Desktop
            jbowden Adobe Employee

            Hi there,

             

            Not sure what may be going on without seeing your site or the Animate composition, but I can tell you that autoplay does work in all HTML 5 desktop browsers. You shouldn't need to add any extra code to make that happen. Maybe you can share a link to the site, or your project files?

             

            Thanks,

            Joe

            • 3. Re: Autoplay Sound Not working on Safari & Chrome Desktop
              Denn S Level 1

              The link is in the first post although we have fixed the problem by adding the extra settings. We expected to only to have to turn on autoplay as in this screen shot.

              autoplay.png And that works for all versions of Firefox (desktop, tablet, phone most current). But not in Chrome or Safari. Didn't test in IE as we don't have the most current IE here. But to make it work in the others we had to add playback as in this screen shot. playback.png That makes no sense to me. There is only the single audio and it starts at point 0 and loops. I would expect autoplay to just run it in all browsers that accept autoplay.

              • 4. Re: Autoplay Sound Not working on Safari & Chrome Desktop
                jbowden Adobe Employee

                Hello again,

                 

                Actually, there is a way you could see this behavior: if you're publishing to web with "Publish content as static HTML" checked, autoplay for audio elements doesn't work. That's a bug.

                 

                To get around it, you could:

                1. Add a play action, as you have found
                2. Hand-edit the published HTML file, and delete audio element div that was written out because of the above setting (this won't affect audio playback in any way, except autoplay will now work)
                3. Uncheck "Publish content as static HTML" if you don't actually need it

                 

                hth,

                Joe

                1 person found this helpful