2 Replies Latest reply on Aug 19, 2014 5:51 PM by gruvinnz

    Cannot install Flash v14 on Mac

    sidewinder3000

      hi,

      I'm on a MacBook Pro with Retina (original) running 10.9.3. I have a 750 GB SSD hard drive, 16 GB of RAM, and a 2.7 GHz Core i7 processor.

       

      I've tried installing the latest Flash version 14 to no avail. I wanna scream! Done all the typical stuff (restarting, uninstalling and doing a clean install, checking the plug-in folder for remnants, etc..) none of it works. Wvery time I try to install 14, it downloads ok, starts the install, then stops with an error that says "Error: Unable to proceed with the installation".

       

      I seem to be able to install Flash v12 with no problem, but that has security issues and I want the latest version on my Mac to be safe. Can you help?

       

      Would love advice from someone who is aware of these Flash installer problems and knows a work around.

       

      Thanks in advance!

       

      michael

        • 1. Re: Cannot install Flash v14 on Mac
          sidewinder3000 Level 1

          SOLVED: Adobe staff member Chris Campbell posted this alternative Adobe Flash v14 installer from macromedia.com that solved my problem instantly!

           

          http://download.macromedia.com/pub/flashplayer/current/support/install_flash_player_osx.dm g

           

          You'll see that the installer looks a little different than the standard v14 installer from Adobe.com (the one I was taken to when prompted by the autoupdater). I don't know if it's an older style of installer or a newer one, but the install happened super fast and without a hitch. Good luck!

          • 2. Re: Cannot install Flash v14 on Mac
            gruvinnz Level 1

            Same problem on iMac with OS X 10.9.4.

             

            Using -debug mode of the installer, I see error code 30. This is the same as the problem with Flash Player v13, which if memory serves, was some kind of invalid CPU instruction in the installer, which in turn apparently only occurred on Macs sold between 2009 and 2013. (Obscure Intel chip bug or something?)

             

            The problem was fairly swiftly remedied for v13 but seems to be lagging a bit for the latest v14. How do we notify the right people at Adobe directly - since it seems unlikely they'll be reading this. :-/

             

            Oh ... a work around for the v13 problem was to roll back to v12. (There was a direct download link somewhere that I followed.) However, that version is now blocked from running (presumably) by Safari v7.0.5 on my system.

             

            The link in the previous post is now a 404, by the way and I'm not sure it was trustworthy in any case.