3 Replies Latest reply on Feb 23, 2015 10:33 AM by AdamUllstrom-DB

    (MP) RAM Previews haven't worked reliably since February

    Cory Bauer Level 1

      I was really hoping the CC 2014 update would address this issue I've been experiencing since February, but the issue remains and if anything is worse than ever. Long story short, sometimes RAM previews work as expected (as in I press the RAM preview button and After Effects actually generates a RAM preview) and other times pressing the RAM preview button results in delays ranging from several seconds to several minutes or simply never doing anything at all. Sometimes, it's the horrendous "Initializing Background Processes this may take some time..." message, and other times it's "Rendering frame (MP) 2 of XXX requested" followed by...nothing ever happening. Try to imagine how frustrating this can be when on a deadline or with clients in the room.

       

      I'd read that the size of your project can be a major factor in such delays. Well, I just started a brand new project that contains exactly one asset (a 1920x1080 22-second H264 video file), added a couple filters and clicked RAM Preview, only to be met with the "Rendering frame (MP) 2 of XXX requested" message and no frame ever rendered. Activity monitor showed 8 red "aeselflink (Not Responding) processes that didn't go away when I quit After Effects. I quit After Effects, logged out and back in, relaunched the project and RAM preview worked as expected. As I said, completely unreliable and unpredictable.

       

      I need RAM Previews to work all of the time, not some of the time, and I need them to work with multi-processing enabled. I realize that disabling multi-processing for RAM previews resolves the up-front delays - but using only one of my eight CPUs is NOT a fix (considering each RAM preview would therefore take 8 times longer). Nor is rebooting and relaunching After Effects a dozen times per day a real solution, right?

       

      My system is a 2013 New Mac Pro, 3Ghz 8-Core Intel Xeon E5, 32GB RAM, Dual D300 GPUs running Mac OS X 10.9.3 and purchased in January; I don't recall experiencing the issue prior to the February 13th AE update). The issue is present with both Adobe After Effects CC 12.2 and Adobe After Effects CC 2014 13.0. My Memory and Multi-Processing Preferences are in the attached image. I truly appreciate any help that can be offered. Thank you!

       

      M&M.jpg