8 Replies Latest reply on Jun 30, 2014 5:55 PM by johnrellis

    Duplicate hard drives in library module?

    drpr53

      After restoring my photo file structure to my external hard drive I'm showing the external hard drive twice in the library module.  Importing pictures misses my original structure and places them in a lone file in the new second external drive in the library module.  How do I resolve to one drive in the library module?

        • 1. Re: Duplicate hard drives in library module?
          drpr53 Level 1

          This occurred after I re formatted the external and restored my files.

          • 2. Re: Re: Duplicate hard drives in library module?
            johnrellis Most Valuable Participant

            I'm pretty sure we'll be able to correct this. But it could be a little tricky, so we need some details first:

             

            - When you do Library > Find All Missing Photos, do photos from the "original" (first) external drive show up or the "new" (second) one?

             

            - In the, select a top level folder for the first drive, right-click it, and select Show Parent Folder:

            Capture1.png

            Keep doing that until you get to the root folder:

            Capture2.png

            - Repeat that process to show the root folder for the second drive.

             

            - Post a full-resolution screenshot of your entire LR window here.

            • 3. Re: Duplicate hard drives in library module?
              drpr53 Level 1

              John, thanks for your quick reply.

               

              #1 In find all Missing Photos, the photos do not show up in the second

              drive.

               

              #2  On Show Parent Folder I get an Error message. path from root not unique.

               

              #3 On second drive, clicking on Show parent folder, nothing happens.

               

              Attached screen capture.

               

              Thanks in advance for your time and help.

               

              PRJ

               

               

               

               

              On Sun, Jun 29, 2014 at 1:05 PM, John R. Ellis <forums_noreply@adobe.com>

              • 4. Re: Duplicate hard drives in library module?
                johnrellis Most Valuable Participant

                The screenshot didn't come through (email attachments are ignored).  Come back to the Web and post the shot there (use the camera icon in the reply window).

                • 6. Re: Re: Duplicate hard drives in library module?
                  johnrellis Most Valuable Participant

                  LR is clearly confused.  I notice that the drive's name is "MYBOOk" (lower-case k).  Was that deliberate?

                   

                  Here's what I suggest for working around this bug:

                   

                  1. Backup your catalog.  (You can force a backup by changing Lightroom > Catalog Settings > Back Up Catalog to "When Lightroom next exits" and then exiting.  Don't restart LR.

                   

                  2. In Finder, rename the drive by right-clicking it (under Devices) to something completely different, e.g. "New MYBOOK".

                   

                  3. Restart LR.

                   

                  4. The left-hand Folder pane should look something like this, with all the top-level folders now marked with a "?" indicating they are missing:

                  Capture.png

                  5. Right-click each of the top-level folders of each of the "MYBOOk" drives and do Find Missing Folder.  Navigate to and select the corresponding folder on the newly renamed "New MYBOOOK".  (I've observed that sometimes you have to do this more than once -- it doesn't seem to always "take".)   If you get a message that the folder is already in LR, select "Merge".

                   

                  6. When you've done this for all the folders on the two "MYBOOk" drives, you should now just have one drive "New MYBOOk".  If there folders from the "MYBOOk" drives still showing up, they should be marked with a "?" and show zero photos.  You can right-click them and do Remove.

                   

                  7. In a catalog without inconsistencies, I've verified that this procedure works.  Yours has inconsistencies, so it may not work.  But that's why you have a backup to revert to if it doesn't.

                  • 7. Re: Duplicate hard drives in library module?
                    drpr53 Level 1

                    John,

                     

                    That resolved the conflict.  Thanks for your patience and help.

                     

                    PR Johnson, Jr.

                     

                     

                    On Mon, Jun 30, 2014 at 4:48 PM, John R. Ellis <forums_noreply@adobe.com>