3 Replies Latest reply on Jul 3, 2014 11:03 AM by Tim Kurkoski

    AE CC 2014 & Blackmagic

    holmesy388

      I've installed AE CC 2014 as part of my subscription and after a bit of mucking about (when i finally found out not all resolutions are supported) to get my Blackmagic ultrastudio mini-monitor to work. My problem is now that there is a severe latency from what's showing on my broadcast monitor and what's happening on the computer monitor when i'm RAM previewing. In fact, it's actually pretty well useless to use. I never had this problem with any other versions of AE CC - in fact, it's so bad i'm going back to the previous iteration of AE CC until I can resolve the problem.

       

      I presume it's something to do with the Mercury Transmit & Blackmagic (I have downloaded the latest drivers form Blackmagic as well - 10.1.2) - is anyone else having this issue? II'd really like to start using AE CC 2014 but am hamstrung at the moment.

       

      My equipment is:

       

      MacBook Pro.

      Blackmagic Mini-monitor (10.1.2 drivers) running off thunderbolt.

      Lacie 5Big 10TB Thunderbolt drives.

       

      cheers

        • 1. Re: AE CC 2014 & Blackmagic
          Tim Kurkoski Adobe Employee

          Describe what you're rendering in your comp. What are the comp dimensions and frame rate? What is the project color depth? Is color management enabled for the project?

           

          How much RAM is in the machine? Is multiprocessing enabled, and if so what are your settings in the Memory & Multiprocessing preferences?

           

          All of the above can have an impact on the performance of video preview. The basic equation is that higher memory requirements for your comp create a bigger impact on playback performance, which is ultimately determined by the capabilities of your machine. Mercury Transmit in general allows better performance than the previous video preview technology, with one caveat: the Mercury Transmit frames are generated asynchronously, which means that the main After Effects process is not waiting on Mercury Transmit to complete its work, but it also means that if the computer is being pushed into a low-memory state then the Mercury Transmit frames may start to lag.

           

          To improve performance with video preview, disable color management, reduce the project color bit depth, and/or reduce the comp resolution and frame rate in the Preview panel. Disabling multiprocessing or reducing the number of cores may also help, in order to free more memory space for Mercury Transmit to use. Multiprocessing otherwise does not affect the performance of video preview.

           

          More information about video preview with Mercury Transmit is here:

          http://bit.ly/AE_video_preview

          • 2. Re: AE CC 2014 & Blackmagic
            holmesy388 Level 1

            thanks for your reply Tim - I've got a 1920x1080 comp @ 25fps, there's 13gig of RAM allocated to AE & it's a 16 bpc project.

             

            I took on board your suggestions of turning colour management off, reducing the colour depth to 8bpc & turned off multi-processing. This all helped greatly so thank you for that. I guess my question now is do I need to turn multiprocessing back on when I do my final render (obviously I'll need to turn my bit depth back to 16) or is there no speed advantage doing this? also, Ive noticed I have no option for audio to go through my Blackmagic device - it now is feed out of my computer output - is this something that is permanent or is it a Blackmagic issue? I ask because the client audio monitoring in my suite comes out of the Blackmagic at the moment,

             

            Regards,

            Jon

            • 3. Re: AE CC 2014 & Blackmagic
              Tim Kurkoski Adobe Employee

              You can definitely reenable multiprocessing for your final render. You may be able to enable it for RAM preview, too. Experiment with it. Multiprocessing doesn't directly affect the speed of RAM preview playback, but it does reduce the amount of memory available to the main After Effects thread, which could contribute to the performance problems when video preview is enabled.

               

              Regarding Blackmagic audio, my understanding is that they have changed the way their audio drivers work in their latest release. If the Blackmagic device is not available in Preferences > Audio Hardware, or as a device in System Preferences > Sound, you may need to roll back to an earlier version of the driver to regain that functionality. Contact Blackmagic for more information about this change to their drivers.