6 Replies Latest reply: Jul 2, 2014 11:14 AM by Aimster RSS

    RH10 fails to generate TOC or index

    Aimster

      RH10 did not generate TOC or index after I updated a project by reorganizing and deleting several topics. I used the broken links editor to create new links but this did not solve the problem.

        • 1. Re: RH10 fails to generate TOC or index
          Captiv8r CommunityMVP

          Hi there

           

          Are you saying there simply isn't a TOC or Index and there was before?

           

          Ore are you instead saying that you updated things and added and deleted topics but the changes aren't being seen in the TOC or Index?

           

          Cheers... Rick

          • 2. Re: RH10 fails to generate TOC or index
            Aimster Community Member

            Hi, Rick, There was a full TOC and index for this project before I updated it. After I saved my changes and generated the Primary Layout (WebHelp), I clicked View Results and discovered the TOC and index had disappeared and using the Search function yielded no results.

             

            When I opened the Table of Contents folder in the Project Manager pane, the TOC was there. Similarly, when I opened the Index folder in the Project Manager, the index was there as well.

             

            I noticed there were some broken links so I used the Broken Link Editor to create new ones but that had no effect on the missing TOC and index. It seems like this must be a link issue. It also seems like there must be a relatively short list of circumstances that cause this specific problem. Unfortunately, I'm a fairly new user of RoboHelp and don't have a lot of troubleshooting skills at this point.

             

            I really do appreciate your response to my issue.

             

            Thanks,

            Amy

            • 3. Re: RH10 fails to generate TOC or index
              Captiv8r CommunityMVP

              Hello again

               

              Okay, likely you just need to examine your Single Source Layout properties and specifically select the TOC and Index files to be used. Maybe something about the upgrade caused the files to have different file names or something.

               

              Cheers... Rick

              • 4. Re: RH10 fails to generate TOC or index
                Aimster Community Member

                Thanks, Rick,

                 

                I checked the properties for WebHelp (Primary Layout) and the appropriate TOC and index were selected. I did notice that an incorrect CSS was selected so I corrected that but it didn't affect the problem.

                 

                Out of curiosity, I checked properties for WebHelp Pro and the TOC and index were set to Default so I selected the correct ones. When I generated, I got an error message saying "Window Properties and Project merging cannot be viewed using Preview. To test all functionality, publish your project to the RoboHelp Server."

                 

                Out of even more curiosity, I opened the Microsoft HTML Help properties dialog, which had the correct TOC and index selected, so I generated there. It generated with the TOC and index in place, just as they should have been after generating in WebHelp.

                 

                Thanks,

                Amy

                • 5. Re: RH10 fails to generate TOC or index
                  Captiv8r CommunityMVP

                  Hello again

                   

                  In this case it would seem you may need to apply some RoboHelp patches. Check out the link below and take those steps.

                   

                  Click here to view

                   

                  Cheers... Rick

                  • 6. Re: RH10 fails to generate TOC or index
                    Aimster Community Member

                    Hi again, Rick,

                     

                    I installed the files included in the RH10 patch, restarted and regenerated, and there they were -- the TOC and index, right where they should be. The Search function works as well.

                     

                    Thanks so much for sharing your knowledge about RoboHelp.

                     

                    I really appreciate it.

                     

                    Thanks,

                    Amy