7 Replies Latest reply on Aug 21, 2014 3:24 AM by Jiheffe

    Nik Software

    Pehem

      While trying to open some photographs with Nik HDR, I got the following message:

       

      "The procedure entry point_crtCreateSymbolicLinkW could not be located in the dynamic link library MSVCR110;dll".

       

      Then , when I clicked "OK", I got:

       

      "Error Launching external application failed"....which is quite an obvious a message!

       

      I also tried other plug-ins of the nik series: Silver Efex, etc,  to no avail: same message again and again.

       

      A few elements for information:

       

      - yesterday, everything functioned well;

      - today, after facing the described problem, I uninstalled both Lr 5.5 and the Nik software bundle, and reloaded the entire stuff... but the problem persists.

       

      Is there anyone who could help me to solve this problem?

       

      Thanks in advance.

       

      Paul

        • 1. Re: Nik Software
          Samoreen Level 2

          Hi,

           

          This message means that the code in the Nik Plugin is looking for a function that resides in the MSVCR110 DLL and that it didn't find it. MSVCR110.DLL belongs to the MSVC runtime library (a code library used by programs written using the Microsoft Visual C++ compiler - to make things short).

           

          Possible reasons for which the crtCreateSymbolicLinkW function could not be found :

           

          - Wrong version : in that case, try to uninstall Microsoft Visual C++ 2012 Redistributable (x86) or (x64) - 11.0.xxxxx from the Control Panel before reinstalling the Nik package. If this succeeds, this could mean that another application has been installed meanwhile and that it overwrote the existing version with something older or aimed at another operating system.

           

          - Corrupted or contaminated version of MSVCR110.DLL. Did you install something dubious yesterday? Did you make a computer scan with your antivirus?

           

          Which version of Windows are you running?

          • 2. Re: Nik Software
            Pehem Level 1

            Thanks for your prompt answer.

             

            I did not install anything new recently, and my antivirus saus that everything is OK.

            I try your suggestion (uninstall Visual C++...). I'll keep you informed.

            My version is Windows 7

            Thanks again.

             

            Paul

            • 3. Re: Nik Software
              Pehem Level 1

              Hello Samoreen,

               

              I followed your suggestion (uninstalled Micrososft Visual C++..., uninstalled Nik collection and re-intalled it) and now everything seems to function properly. I tried HDR, Viveza, Sharpener, Dfine, Silver Efex, etc... Looks good.

               

              I'll keep you informed if anything goes wrong again.

               

              Many thanks for your rapid and efficient support.

               

              Regards,

               

              Paul

              • 4. Re: Nik Software
                Samoreen Level 2

                Hi again,

                 

                I looked at the Nik plugins and could see that they do not use the _crtCreateSymbolicLinkW function (which at first sight was very strange : plugins don't need this function, I guess). The "Error Launching external application failed" message seems to indicate that Lightroom or one of its DLLs needs to call this function. So the problem seems to be related to the process triggered when using the Edit in... command in Lightroom. So you should have a look at your Preference settings in the External Editing tab. Something might be wrong there. You should also check whether you also have the problem with other plugins, not only with the Nik plugins.

                 

                Also in your first message you mentioned in the dynamic link library MSVCR110;dll . Is the semicolon after MSVCR110 a typo or is this displayed this way ? There should be a dot there. Not a semicolon.

                • 5. Re: Nik Software
                  Samoreen Level 2

                  Oooooops! I didn't see your answer before sending the previous message.

                   

                  Glad that everything is running fine now.

                   

                  Greetings from Fontainebleau, France.

                  • 6. Re: Nik Software
                    Pehem Level 1

                    Thanks again. Indeed the « ; » was a typo….

                    • 7. Re: Nik Software
                      Jiheffe Level 1

                      Not sure Nik is the culprit here... I ran in the same problem here. Could't even start PS CC stand alone. Uninstalling and reinstalling NIK didn't help... I reinstalled the Visual C++ 2012 distributable, doing a "Repair" and that worked.