10 Replies Latest reply on Oct 24, 2014 7:39 AM by reddet

    Flash not pulling updates from internal server

    Neil_Gascoigne

      Hi

       

      About two years, I configured an internal server to distribute Flash updates to Windows endpoints. This has been working well, until it appears, this May.  My endpoints are therefore stuck on 13.0.0.214. So something has changed

       

      Checks I've made:

       

      1. Update script on the server still pulls files. Destination folder shows v14 has been downloaded

       

      Pulling the version.xml from the internal update server (over https) confirms this.

       

      For info:

      <version>

       

      <ActiveX major="14" minor="0" buildMajor="0" buildMinor="145"/>

       

      <Plugin major="14" minor="0" buildMajor="0" buildMinor="145"/>

      <MacPlugin major="14" minor="0" buildMajor="0" buildMinor="145"/>

      <SAUConfig checkFrequency="1"/>

      </version>

       

      2. CNAME "flashupdate" is still in DNS

       

      3. Domain wildcard cert is valid and bound to HTTPS such that I get no cert warnings when browsing to the internal update server https://flashupdate.domain.local (IIS 7)

       

      On an endpoint, here is a sample flashinstall.log (can't find what the error codes mean!) for about the last 30 mins. I've been using FlashPlayerUpdateService.exe to kick it off manually.

       

      2014-7-9+14-45-44.830 [info] 1628 flashupdate.domain.local

      2014-7-9+14-45-44.830 [info] 1629 flashupdate.domain.local

      2014-7-9+14-45-44.831 [info] 1614

      2014-7-9+14-45-44.831 [info] 1616

      2014-7-9+14-45-44.832 [info] 1618

      2014-7-9+14-45-44.835 [info] 1608

      2014-7-9+14-45-44.835 [info] 1612

      2014-7-9+14-45-44.837 [info] 1620

      2014-7-9+15-18-0.225 [info] 1628 flashupdate.domain.local

      2014-7-9+15-18-0.236 [info] 1629 flashupdate.domain.local

      2014-7-9+15-18-0.238 [info] 1614

      2014-7-9+15-18-0.239 [info] 1615

      2014-7-9+15-18-0.240 [info] 1618

      2014-7-9+15-18-0.242 [info] 1619 1063

      2014-7-9+15-18-0.282 [info] 1628 flashupdate.domain.local

      2014-7-9+15-18-0.283 [info] 1629 flashupdate.domain.local

      2014-7-9+15-18-0.283 [info] 1614

      2014-7-9+15-18-0.284 [info] 1615

      2014-7-9+15-18-0.284 [info] 1618

      2014-7-9+15-18-0.287 [info] 1608

      2014-7-9+15-18-0.288 [info] 1612

      2014-7-9+15-18-0.289 [info] 1620

      2014-7-9+15-18-0.289 [info] 1604

       

      Here's an LS output on the endpoint for C:\Windows\SysWOW64\Macromed\Flash showing that nothing is changing

       

      total 43871

      -r--r--r--   1 user     group    16435888 May 15 12:18 Flash32_13_0_0_214.ocx

      -rw-rw-rw-   1 user     group     4609272 Jul  9 16:18 FlashInstall.log

      -rwxrwxrwx   1 user     group     1863856 May 15 13:18 FlashPlayerPlugin_13_0_0_214.exe

      -rwxrwxrwx   1 user     group      257712 May 15 13:18 FlashPlayerUpdateService.exe

      -rw-rw-rw-   1 user     group      511152 May 15 12:18 FlashUtil32_13_0_0_214_ActiveX.dll

      -rwxrwxrwx   1 user     group      847536 May 15 12:18 FlashUtil32_13_0_0_214_ActiveX.exe

      -rwxrwxrwx   1 user     group      847536 May 15 13:18 FlashUtil32_13_0_0_214_Plugin.exe

      -rw-rw-rw-   1 user     group    16361136 May 15 13:18 NPSWF32_13_0_0_214.dll

      -rw-rw-rw-   1 user     group     1583299 May 15 12:18 activex.vch

      -rw-rw-rw-   1 user     group         856 May 15 13:18 flashplayer.xpt

      -rw-rw-rw-   1 user     group           0 Jul  9 16:25 ls.txt

      -rw-rw-rw-   1 user     group         135 Jul  9 15:52 mms.cfg

      -rw-rw-rw-   1 user     group     1598803 May 15 13:18 plugin.vch

       

      The mms.cfg looks like:

      AutoUpdateDisable=0

      SilentAutoUpdateEnable=1

      SilentAutoUpdateServerDomain=flashupdate.domain.local

      SilentAutoUpdateVerboseLogging=1

       

      I know that

      1. the internal update server is able to contact Adobe and download updates (I've used wget in verbose mode to verify the output).

      2. On the endpoint, I manually browse and download the updated v14 files without issue, so web-hosting permissions and config appears ok

      3. The endpoint update for some reason steadfastly refuses to pull the updated files. The clue therefore appears to be in the mysterious error codes?

       

      So I'm stuck - please help!

        • 1. Re: Flash not pulling updates from internal server
          Neil_Gascoigne Level 1

          Hi, just to date. I've found that the V14 deployment guide has slightly changed and there are now 14 files to pull. I've download the latest Background Update package from http://download.macromedia.com/pub/flashplayer/current/licensing/win/fp_background_update. cab and extracted to the correct location as per procedure.

           

          However flashinstall.log is unchanged.

          • 2. Re: Flash not pulling updates from internal server
            Neil_Gascoigne Level 1

            I reported the above to Support this morning over the phone. This afternoon, mysteriously, endpoints have started to pull down the V14 update.  That's a bit odd!

            • 3. Re: Flash not pulling updates from internal server
              m_vargas Adobe Employee

              Hello,

               

              I'm glad this is working for you now.

               

              The install log file you posted doesn't contain any errors, just informational codes that indicate proper functionality of the background update functionality.

               

              To clarify one of your points, the internal update server does not communicate with the Adobe servers to download the update package.  As the Administrator, you or someone else, would need to download the update package (fp_background_update.cab) and post the files (in the structure provided) to your internal server.  This is a manual process unless you automate it.  Once the files are posted to your server, it can take up to an hour for the updates to start showing up on your users machines (of course, depending how your environment is set up, you may been to clear your server's cache in order for the new files to be downloaded).

               

              --

              Maria

              • 4. Re: Flash not pulling updates from internal server
                TechSupportGuy Level 1

                I am having a similar issue today trying to update to version 15.0.0.152. My log looks the same however I do notice in my log I have the following:

                 

                2014-9-22+10-41-0.265 [info] 1631 /pub/flashplayer/update/current/sau//currentmajor.xml

                2014-9-22+10-41-0.345 [info] 1630 /pub/flashplayer/update/current/sau/14/xml/version.xml

                 

                I am thinking my client still thinks we are on 14 and that is why I haven't gotten the update? I replaced the files in the SAU folder and still haven't had any luck.

                Following the above my log shows this

                 

                2014-9-22+10-41-0.345 [warning] 1411

                2014-9-22+10-41-0.345 [warning] 1409

                 

                Then the following repeats over and over:

                 

                2014-9-22+10-41-0.345 [info] 1612

                2014-9-22+10-41-0.345 [info] 1620

                2014-9-22+11-41-0.235 [info] 1628 wsus.domain.com

                2014-9-22+11-41-0.235 [info] 1629 wsus.domain.com

                2014-9-22+11-41-0.245 [info] 1614

                2014-9-22+11-41-0.245 [info] 1615

                2014-9-22+11-41-0.245 [info] 1618

                2014-9-22+11-41-0.245 [info] 1619 1063

                2014-9-22+11-41-0.285 [info] 1628 wsus.domain.com

                2014-9-22+11-41-0.285 [info] 1629 wsus.domain.com

                2014-9-22+11-41-0.285 [info] 1614

                2014-9-22+11-41-0.285 [info] 1615

                2014-9-22+11-41-0.285 [info] 1618

                2014-9-22+11-41-0.285 [info] 1604

                2014-9-22+11-41-0.285 [info] 1608

                 

                Any help you can give would be much appreciated.

                • 5. Re: Flash not pulling updates from internal server
                  m_vargas Adobe Employee

                  Hello,

                   

                  Please paste a screenshot of the sau directory on your local server and post the currentmajor.xml and version.xml files using the instructions here, The specified item was not found..  Please do not copy and paste the files.

                   

                  --

                  Maria

                  • 6. Re: Flash not pulling updates from internal server
                    TechSupportGuy Level 1

                    Capture.JPG

                     

                    do I need a version.xml in the SAU folder as well?

                     

                    Currentmajor.xml contains the following..

                     

                    <version>

                    <Player major="15" majorBeta="15"/>

                    </version>

                     

                    I downloaded the CAB file from the website extracted it and that is what I got. Copied the files out to the server under SAU and no luck..

                    • 7. Re: Flash not pulling updates from internal server
                      m_vargas Adobe Employee

                      The version.xml file is saved inside the xml directory in each of the /11, /14, and /15 sub-directories, and Flash Player knows which directory to go to based on the version currently installed.  Please post (The specified item was not found.) the /pub/flashplayer/update/current/sau/14/xml/version.xml file and the entire FlashInstall.log file.  Please don't copy the contents into the response.  Also, which version of 14 is currently installed on the system?

                       

                      You may also need to delete the following two registry entries, as they may be interfering with your testing:

                      • On a 32-bit OS, delete:
                        • HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayer\LastUpdateCheck\
                        • HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayer\UpdateAttempts\
                      • On a 64-bit OS, also delete:
                        • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Macromedia\FlashPlayer\LastUpdateCheck
                        • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Macromedia\FlashPlayer\UpdateAttempts
                      • 8. Re: Flash not pulling updates from internal server
                        TechSupportGuy Level 1

                        I think I must have had a bad version.xml file in the 14 folder all the sudden my updates started to work.

                        • 9. Re: Flash not pulling updates from internal server
                          m_vargas Adobe Employee

                          Hi,

                           

                          I'm glad it's working now.  The best thing to do is to replace all of the files on your server with the new files in the fp_background_udpate.cab file when we release an update.  This will ensure the files are what the player expects them to be.

                           

                          --

                          Maria

                          • 10. Re: Flash not pulling updates from internal server
                            reddet

                            @TechSupportGuy,

                             

                            What did you do to determine the version.xml was corrupt/bad? I am having the exact same issues you've described.