2 Replies Latest reply: Jul 14, 2014 8:22 AM by IanKaufman RSS

    ColdFusion 11 installer cannot find Apache binary

    IanKaufman Community Member

      Hi,

       

      I am trying to install the latest (as of Monday, 07July2014) CF11 release on an Ubuntu 14.04 LTS system. I know, 14.04 is not officially supported, but the differences between 13.10 and 14.04, at least Apache-wise, are minimal if any. Whenn trying to tell the installer where the Apache binary is located, and supplying the correct Apache 2.4.7 path to /usr/sbin/apache, the installer claims that the file does not exist. I also tried the (incorrect) recommendation posted by others elsewhere of pointing to the shell script /usr/sbin/apache2ctl, but it fails with the same error.

       

      Thanks,

       

      Ian

        • 1. Re: ColdFusion 11 installer cannot find Apache binary
          vishu#13 Community Member

          Ubuntu 14 is not a supported platform for CF 11. Check CF 11 support matrix

          • 2. Re: ColdFusion 11 installer cannot find Apache binary
            IanKaufman Community Member

            Yes, as I pointed out in my question, I am well aware of the fact that CF11 only supports Ubuntu 13.04 and 13.10 non-enterprise grade and no longer supported by Ubuntu OS. However, 14.04 is not very different from 13.10, and the issue is how the CF11 installer handles Ubuntu's deployment of fairly stock Apache 2.4.7.


            Regardless, I figured out the problem - the installer does not like the existence of an httpd.conf file in /etc/apache2. So, it installs and works once I removed the errant httpd.conf file created by an aborted CF9 install, other than some customization we have done for our old CF9 installation. However, the CF11 installer is still very poorly designed as it does not adhere to how Apache 2.4.X (or 2.2.X) and Ubuntu have laid things out. The installer should really place a config file in /etc/apache2/conf-available and create a symlink to it in /etc/apache2/conf-enabled.

             

            Ian