1 Reply Latest reply on May 3, 2007 2:16 PM by liquidleaf

    ActionScript that worked in Studio 8 fails in CS3

    bsalles
      I have three lines in my code that worked just fine using the Flash/Java Integration Kit when the movies I'm creating were built using Studio 8. I upgraded to CS3 and now I can't publish. The three lines are:

      import com.macromedia.javascript.JavaScriptProxy;
      var proxy:JavaScriptProxy = new JavaScriptProxy();

      var proxy:JavaScriptProxy = new JavaScriptProxy(_root.lcId, this);

      The error is that the JavaScriptProxy can't be loaded, but it exists on the server(s) where the final SWF will live. I'm desperate for help. Anyone?

      Thank you so much,
      -Benjamin
        • 1. Re: ActionScript that worked in Studio 8 fails in CS3
          liquidleaf
          Well, if it worked in Flash 8, you can just adjust your publish settings to use "AS2" instead of "AS3". Try that first.

          You may need to copy/paste the appropriate libraries from your Flash 8 program directory into the Flash CS3 directory as well, if they're not there.

          You might want to start using ExternalInterface instead of JavaScriptProxy (ExternalInterface was available as of Flash 8). It makes talking to Javascript MUCH easier.