6 Replies Latest reply on Jul 14, 2014 7:52 AM by kharga

    updating to Lightroom 5

    kharga

      Why must I update my Mac OS to Mavericks to use Lightroom 5? I've tried Mavericks and its absolute RUBBISH. I've gone back to my original OX 10.6.8. Adobe and Apple are now as bad as Microsoft for  empty "upgrades" which are not an upgrade but a step back!!!