8 Replies Latest reply on Dec 20, 2016 5:36 AM by sveinh66407695

    After Effects lights not working

    kparla

      I am working in After Effects CC. I added a light to my scene and it just turns all of my 3d layers black. I am a very seasoned AE user. I have worked with lights before. I don't know what is going on here. It's not a draft mode issue. And my lights are not behind my layers or anything like that. I have found other people in the online forums with this problem from over the years but never a solution. Ambient light is the only light that works. Spot, pin, and parallel turn everything black. Thoughts?

        • 1. Re: After Effects lights not working
          Rick Gerard Adobe Community Professional & MVP

          Select the light, press the a key twice to reveal all of the properties, make sure that the light has a positive value. Check the light falloff if you happen to have a version that supports that. Then do the same with the 3-D layers and make sure they are set to receive lights.

           

          if that doesn't do it then tell us how your composition is set up, classic or ray traced, and tell us what effects you have applied to any of the layers.

          • 2. Re: After Effects lights not working
            kparla Level 1

            Once the problem presented itself I started fresh with a new project and very simple comp and still had the same problem.

            So my settings are pretty straightforward.

            I am using After Effects CC (not the 2014 version)

            I have one 3d solid that I pushed back in z-space. It is set to receive lights.

            I am using Classic 3d.

            I created a new spot light.

            The settings are as follows:

            Intensity: 100%

            Color: white

            cone angle 90

            cone feather 0

            falloff smooth

            radius 75

            Falloff distance 24

            Casts Shadows on

            Shadow Darkness 20%

            Shadow Diffusion 0

             

            If I turn my light off you see my solid. If I turn it on you see only blackness.

            If I add a 2d layer you can see it. Once I make it 3d, it turns black.

             

            Thanks for any advice you have. I'm guessing I probably need to do a clean install or something because this is crazy. It's not like I've never used lights before. They just up and stopped working.

            • 3. Re: After Effects lights not working
              kparla Level 1

              Also, if I apply Trapcode Lux, the light shows up. It still doesn't light anything up but Lux makes the light itself visible. So I know the light is there. It just won't light anything.

              • 4. Re: After Effects lights not working
                Rick Gerard Adobe Community Professional & MVP

                The problem is falloff distance and radius. With the fall off distance at 24 and the radius 75 when you light is 24 pixels away from the 3D layer the spot of light will be 75 pixels wide. By the time you move the light about 100 pixels (4 times the distance) the falloff will be nearly complete so no light will fall on the layer. Change the falloff to Inverse squared and you'll be able to move the light about another 100 pixels away before the light no longer reaches the layer. Set the falloff to None and the falloff distance and radius will have no effect. The radius also effects the distance where the lights stop reaching the lights. If you want falloff then you'll have to experiment with these settings to get the lights to behave as you want them to but 24 and 75 are way too small for a reasonable 3D lighting setup.

                1 person found this helpful
                • 5. Re: After Effects lights not working
                  kparla Level 1

                  Okay I will check. I changed all of these parameters a bunch of different ways and move the light in and out. So I'm not sure if that's the issue. But I'll check.

                  • 6. Re: After Effects lights not working
                    kparla Level 1

                    Alas, you are correct! Thank you so much. I don't know why the radius was set so small. I kept trying to reset to a default setting but it wouldn't. I think maybe I was using lights to drive some other effect in a previous project and then it copied those settings or something. Can't recall. Anyway it's much better now. Thanks so much.

                    • 7. Re: After Effects lights not working
                      Rick Gerard Adobe Community Professional & MVP

                      Glad to help. Please mark my reply as answered so others can find the solution if they run into the same problem.

                      • 8. Re: After Effects lights not working
                        sveinh66407695

                        Had the same problem, happened after updating to CC17, all works fine after tweaking the parameters in mention, thank you