1 Reply Latest reply on Jul 19, 2014 1:27 AM by hmilas

    Ray-traced 3D not working because of CUDA -> solution

    Daniel Keiling Level 1

      Hi everybody,

       

      I just faced a problem working with After Effects on mac after installing Davinci Resolve. Everytime I activate the ray-traced 3D renderer and hit 3D in any of the layers, an error message shows up saying that there´s not enough memory for the renderer and that you should perform a CUDA update.

       

      Now Resolve comes with NVidia CUDA drivers which´s UI can be found in the system preferences. It will be installed wether you have a compatible NVidia card or not.

       

      Now, if you´re not able to use the ray-traced 3D renderer in AE anymore, the CUDA drivers are the reason for that.

       

      To remove all the CUDA components, delete the following files and reboot after:

       

      /Library/Frameworks/CUDA.framework

      /Library/LaunchAgents/com.nvidia.CUDASoftwareUpdate.plist

      /Library/PreferencePanes/CUDA Preferences.prefPane

      /System/Library/Extensions/CUDA

      /System/Library/StartupItems/CUDA

      /usr/local/cuda/lib/libcuda.dylib

       

      (source: uninstall nvidia drivers | Apple Support Communities)

       

      You may use the terminal to open the directories or hold alt while clicking on Go to at the finder´s top bar, which shows up the library there.

       

      After rebooting the drivers are gone (check the system preferences). Worked fine for me!