4 Replies Latest reply on Jul 31, 2014 1:13 PM by oakandleaf

    Bullets in NVDA not reading in the right language

    oakandleaf

      I have a document where all of the language is in Spanish. I've set the NVDA screen reader to read in Spanish, as well as the pdf document language and the text in indesign where I created the file. All is well except when it comes to bulleted lists, it still reads "bullet" in English followed by the text in Spanish. For example, "• Pago con demora" reads "Bullet Pago con demora"

      I even checked my punctuation/pronunciation settings in NVDA and they are set to read bullets as "viñetas". Any thoughts?

        • 1. Re: Bullets in NVDA not reading in the right language
          a C student Level 3

          I would check in the tags pane to see if the bullets have alt text applied, or possibly the language just for the bullets is set to English. Each bullet should be tagged as a label <Lbl>, but might instead be inside a <Span> tag within the list body <Lbody>. If you right click the tag containing the bullet and select Properties you can quickly see if alt text or language is set. 

          • 2. Re: Bullets in NVDA not reading in the right language
            oakandleaf Level 1

            Thanks so much for your help.

             

            Here is what the tags look like, is this correct? Should that <span> tag not be there?

            Screen Shot 2014-07-18 at 12.54.17 PM.png

             

            I've checked everything and all of the paragraph styles, text, document language etc and they are all set to spanish. In the tag properties, I also checked the language, and for some reason it wasn't showing a language, even though I set the language for the document. But even when I selected spanish for the bullets it still reads incorrecty. There is no alt text.

            • 3. Re: Bullets in NVDA not reading in the right language
              a C student Level 3

              The list tag structure looks fine. The Span tag is not necessary but also causes no harm. I assume you checked for alt text in the properties of the Span and Lbl tags? If so, sorry, I have no other ideas of what might be going wrong.

              • 4. Re: Bullets in NVDA not reading in the right language
                oakandleaf Level 1

                Ok I figured it out, just in case anyone else has run into this problem. Under general settings in the NVDA screen reader there is an option for it to automatically detect language. It appears it was automatically assuming the bullets were English even though the language was not set to that. I unchecked that preference and all was fixed with the bullet issue. Still doesn't explain why some of my numbers within the document are reading in English though.