1 Reply Latest reply on Jul 21, 2014 10:20 AM by dj_paige

    I have lightroom 4.4 and it does not support Canon EOS 70D what to do?

    lourav

      I have lightroom 4.4 and it does not support Canon EOS 70D raw files. What do I do?