14 Replies Latest reply on Aug 13, 2014 7:42 AM by Jeff_Coatsworth

    breadcrumbs

    a_neises

      I am running RoboHelp 10. My Help output is HTML, generated from the WeHelp target. The output opens in IE 10. The issue has to do with breadcrumbs.

      When users launch Help from within the application, from a location that links to the Index.htm file, breadcrumbs display at the top of the window.

       

      But, when users launch Help from a location that links to Help using context IDs, the open window cuts off the breadcrumbs. Users need to scroll up to view them. If users do not know to scroll up, they cannot navigate to other topics within Help.

       

      How can I fix the output, so that users don't need to scroll up to view the breadcrumbs?

        • 1. Re: breadcrumbs
          Captiv8r Adobe Community Professional & MVP

          Hi there

           

          It would be helpful to know more about how your help is structured.

           

          From what you described, it sounds as if your help is just one very long topic and the context sensitive call is opening to a bookmark.

           

          Can you share some screen captures to illustrate?

           

          Cheers... Rick

          • 2. Re: breadcrumbs
            a_neises Level 1

            Hey Rick,

            Thanks for getting back to me. Here is how the Help is structured:

             

            1. This is how Help displays after users click a Help button. The Help button is not associated with a context ID.
            without context id.jpg

             

            2. This is how the Help displays when users select to open a topic associated with a context ID. Note that the breadcrumbs do not appear at the top of the window.

            without breadcrumbs.jpg

             

            3. The breadcrumbs do display after users click and drag the scroll bar up. My developers are asking that the topic opens so that users do not have to scroll to view breadcrumbs.

            with breadcrumbs.jpg

            • 3. Re: breadcrumbs
              Captiv8r Adobe Community Professional & MVP

              Are you linking via Map IDs?

               

              If so, in the Map ID dialog, are you linking to a bookmark? That's the only thing I can think of that would cause this kind of behavior.

               

              Cheers... Rick

              • 4. Re: breadcrumbs
                a_neises Level 1

                Actually, I'm linking to topics. Here's a screen shot to illustrate:contextid.jpg

                • 5. Re: breadcrumbs
                  Jeff_Coatsworth Adobe Community Professional & MVP

                  I get the same result when my source material is coming in from FM. The MapID comes over as the marker text associated with a CSH marker that is positioned on the same line as the topic title. I think it gets converted to a bookmark in RH at the beginning of the line. Opening the help from the application positions the browser at the topic title – you can actually see it shift itself down from the top of the topic to the title in the pop-up. I suspect it’s something in the CSH launching JS.

                  • 6. Re: breadcrumbs
                    a_neises Level 1

                    This makes sense: my Help is single-sourced from FrameMaker. However, my CSH markers are set up in RoboHelp, not FrameMaker.

                    Could this issue duplicate, under these circumstances?

                    • 7. Re: breadcrumbs
                      Captiv8r Adobe Community Professional & MVP

                      Hi there

                       

                      One way to easily check for this is to examine the topic. Depending on how the bookmark was created, if one exists, you will find either a small white flag symbol or the words will be presented in the color green.

                       

                      Cheers... Rick

                      • 8. Re: breadcrumbs
                        Jeff_Coatsworth Adobe Community Professional & MVP

                        Yup, I’m seeing a little bookmark flag positioned exactly at the end of the topic title in the place where my CSH marker is in FM.

                        • 9. Re: breadcrumbs
                          Jeff_Coatsworth Adobe Community Professional & MVP

                          Just noticed something – this only seems to occur when the topic contents can’t all fit within a single window - if there’s a scroll-bar needed, the topic starts at the topic title line; if no scrolling is needed, the topic begins with the Show link and breadcrumbs at the top of the page. Hmm…

                          • 10. Re: breadcrumbs
                            a_neises Level 1

                            Interesting. Thank you for the update. I am now testing the delete bookmarks theory, and will give an update after I post the files. I'll also check on the scrolling, to see if that duplicates in my environment.

                            • 11. Re: breadcrumbs
                              a_neises Level 1

                              Hello,

                              My developers just let me know that the fix did not work. Instead, it complicated matters: after I deleted the bookmarks, the context IDs no longer work in Help.

                               

                              Is there anything else we can do?

                               

                              Thanks!

                              • 12. Re: breadcrumbs
                                Jeff_Coatsworth Adobe Community Professional & MVP

                                Where did anyone suggest deleting the bookmarks? I think we’re just seeing an artefact of launching CSH help with a scroll bar present; if the called topic is short enough, the scroll bar doesn’t appear & the breadcrumbs and Show link are visible at the top immediately.

                                • 13. Re: breadcrumbs
                                  a_neises Level 1

                                  OK! So it sounds like this can be fixed if the window containing the Help consistently opened up in a larger size. Is this correct? If "yes," is this something that I can adjust in RoboHelp settings, or is it something that needs fixing on the developer side?

                                  • 14. Re: breadcrumbs
                                    Jeff_Coatsworth Adobe Community Professional & MVP

                                    I don’t know of any tweak you can make via the RH interface – I think it has to do with the method used to launch CSH