4 Replies Latest reply on Oct 3, 2014 8:33 AM by lgannarelli

    How can I turn off the Typekit font check when opening files in InDesign

    Adrian Birch

      Adobe InDesign CC, Version 9.2.1 x32

      Windows 7 Professional 64 bit

      Every time I open an existing file in InDesign which is using a font I have installed on my PC I get the following message:
      "No matches were found on TypeKit, click "Find Font" to replace with fonts that exist on your computer"

       

      I'm able to click on Find Font and then select the font that TypeKit is unable to find - can I stop it checking for this as I have the font installed on my local machine?

      Many thanks.

        • 1. Re: How can I turn off the Typekit font check when opening files in InDesign
          KrishnaGopa

          Hey Adobe, I would like an answer for this too. Typekit is intrusive and unnecessary for my work flow.

          • 2. Re: How can I turn off the Typekit font check when opening files in InDesign
            Ben, Typekit Support Adobe Employee

            Hi Adrian,


            I'm sorry that you ran into trouble with this. Some users have reported an issue in the current version of InDesign which can temporarily deactivate installed fonts. Please note that this is actually unrelated to Typekit; it just happens to occur at the time you see our logo in the missing fonts window.

             

            The InDesign team is still investigating the factors which trigger this situation, but the basic issue is this: the Missing Fonts dialog causes fonts which are managed through Extensis Suitcase and FontExplorer to not auto-activate correctly, or for managed fonts to even be visible in the application after upgrade.

             

            In both cases, the InDesign Missing Fonts dialog appears to override the Font Management tool dialogs that allow users to manage fonts within the Application.

             

            If you use Suitcase Fusion, there is a simple configuration change needed:

            1. close the Missing Fonts window

            3. go to the Type menu and select "Suitcase Fusion 5".

            3. From the submenu, choose "Library" and then check "All Libraries" so all fonts can be auto-activated as needed

            4. from the Type menu, select "Suitcase Fusion 5" again, and then "Check Document’s Fonts" to activate the missing fonts,

             

            If the font is being managed by Suitcase, it will find and update the fonts.


            In FontExplorer, if your managed fonts are not visible in InDesign after upgrading to InDesign 9.2

             

            Go to FontExplorer/Tools and select

            1. Clean System Font Caches (this will require a system reboot)

            2. Clean Application Font Caches

             

            On non-Mavericks systems, you will need to de-activate and then reactivate font protection.  Launch a terminal window and enter


            sudo atsutil fontprotection -off

            Then enter

            sudo atsutil fontprotection -on

             

            Relaunch InDesign. your managed fonts should now be visible and auto-activation should work.

             

            The fonts can always be activated from within the Font Management software itself, even with the missing fonts dialog open.

             

            The InDesign team is looking into the issue to determine the root cause as well; our apologies for any inconvenience it causes in the meantime.

             

            Cheers,

            Benjamin

            • 3. Re: How can I turn off the Typekit font check when opening files in InDesign
              David Cardillo Level 1

              Ben, is this still an issue in the 2014 version?

              • 4. Re: How can I turn off the Typekit font check when opening files in InDesign
                lgannarelli

                Adobe,

                 

                I'm having the same issues and I use a font manager application program and it's messing up my style sheets and I'm super frustrated! It's a lot of work to get the fonts into place correctly to work! Also, I find it interesting that in Illustrator you can "shut it off" but not in InDesign? Why can you do it in one application but not another?