7 Replies Latest reply on Jul 24, 2014 3:44 PM by ssprengel

    I purchased lightroom 5 but I need version 4

    Hight00024

      I purchased Lightroom 5 for MacOS, but I will need version 4 for it to work on all the Mac in our school computer lab.  How do I return or down grade this software?