2 Replies Latest reply on Jul 24, 2014 9:15 AM by RikkFlohr

    LR wont let me download says not compatible with my operating sytem, MAC OS X 10.6.8  help!

    meganredfieldcobb

      Please help me with downloading LR with operating system MACE OS X 10.6.8 it says its not compatible and I've already paid for it. My computer is fully updated.