3 Replies Latest reply on Jul 30, 2014 12:34 PM by kglad

    NavigateToURL Works During Testing But Not Once Published

    schranda Level 1

      Trying to create a simply hyperlink in Flash.  Works perfectly during testing.  But when I upload to the net, clicking the link takes me to www.thirdnewhope.com/iamtnh.blogspot.com rather than to just www.iamthn.blogspot.com.  I've tried changing allowscriptaccess to always.  That doesn't work either.  I am stumped :-(

       

      AS3 code:

      button_1.addEventListener(MouseEvent.CLICK, goClick);

      function goClick(evt:MouseEvent):void {

       

         var url:String = "http://www.iamtnh.blogspot.com";

         var req:URLRequest = new URLRequest(url);

       

         navigateToURL(req, "_blank");

       

      }

       

      HTML code:

      <div id="flashContent">

                  <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="560" height="400" id="events2013" align="middle">

                      <param name="movie" value="events2013.swf" />

                      <param name="quality" value="high" />

                      <param name="bgcolor" value="#000000" />

                      <param name="play" value="true" />

                      <param name="loop" value="true" />

                      <param name="wmode" value="window" />

                      <param name="scale" value="showall" />

                      <param name="menu" value="true" />

                      <param name="devicefont" value="false" />

                      <param name="salign" value="" />

                      <param name="allowScriptAccess" value="sameDomain" />

                      <!--[if !IE]>-->

                      <object type="application/x-shockwave-flash" data="events2013.swf" width="560" height="400">

                          <param name="movie" value="events2013.swf" />

                          <param name="quality" value="high" />

                          <param name="bgcolor" value="#000000" />

                          <param name="play" value="true" />

                          <param name="loop" value="true" />

                          <param name="wmode" value="window" />

                          <param name="scale" value="showall" />

                          <param name="menu" value="true" />

                          <param name="devicefont" value="false" />

                          <param name="salign" value="" />

                          <param name="allowScriptAccess" value="sameDomain" />

                      <!--<![endif]-->

                          <a href="http://www.adobe.com/go/getflash">

                              <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />

                          </a>

                      <!--[if !IE]>-->

                      </object>

                      <!--<![endif]-->

                  </object>

              </div>