7 Replies Latest reply on Aug 4, 2015 12:40 AM by De Kruisbestuiving

    shortcuts do not work on numeric keyboard

    OutlineG Level 1

      I recently upgraded to Indesign CC on OSX 10.9.4 (Maverick). Now some shortcuts on the numeric keyboard do not work.

      f.ex the shortcut to superscript is cmd+shift+=, which works fine on the (main) keyboard, but not on the right hand sided numeric keyboard.

      The 1 through 9 work fine (I tested it creating a paragraph style shortcut), but also the comma does not work (again, I tested it making the shortcut  cmd+comma  for "fit in page": works on the main keyboard, but not on the num. keyboard)

       

      My keyboard is azerty and language is french numerical.

      I don't have a seperate num. keyboard, it's the standard Apple keyboard.

       

      Anybody any idea what can cause this, or what I'm doing wrong?

       

      Thanks

      Regards

      Vanessa

        • 1. Re: shortcuts do not work on numeric keyboard
          Peter Spier Most Valuable Participant (Moderator)

          Numpad keys are reserved for style shortcuts, and style shortcuts can only use numpad keys plus a modifier.

          • 2. Re: shortcuts do not work on numeric keyboard
            OutlineG Level 1

            That is very strange, as cmd+comma has been my shortcut for "fit in window" for ages in Indesign, and it's only since the CC that it does not work anymore.

            Even more:

            - if I change it in illustrator, it works fine there

            - if I change it to cmd+star that also works in Indesign (star (*)  is also on my num. keys)

            - the DEFAULT shortcut for superscript does not work on the num keys.

            Where's the logic in that??

            • 3. Re: shortcuts do not work on numeric keyboard
              Peter Spier Most Valuable Participant (Moderator)

              What makes you think anything related to Adobe or Apple has a basis in logic?

              • 4. Re: shortcuts do not work on numeric keyboard
                OutlineG Level 1

                In a perfect world...

                 

                I found this in another thread of you

                "OK, NOW edit the keyboard shortcut for Paragraph Break and add NumEnter (press the Enter key on the numpad). If it doesn't register as NumEnter, turn Mumlock on again temporarily and press the key again. Save your custom set."

                Made me think and look closer: my cmd+star actually shows up as cmd+ Num star in the shortcutlist, which makes sense now. But the comma and the = do not register that way... why not? WHY? WHY?

                Is there a way to force the added "Num" so it will work?

                 

                (I now, I should let go by now, but ... )

                • 5. Re: shortcuts do not work on numeric keyboard
                  Peter Spier Most Valuable Participant (Moderator)

                  Well, you could try editing the keyboard shortcuts and make a new set. The quote above sounds like advice I give to users of some PC laptops that are strangely built, but I've never seen a Mac that has the numpad Enter key mapped to the alpha pad by the numlock button...

                  • 6. Re: shortcuts do not work on numeric keyboard
                    OutlineG Level 1

                    it was from a PC thread... I do work on Mac

                    I already made a new set and it appears the only 2 keys not working on Num pad are comma and = (and zero ofcourse) ... Oh well... I'll adapt my set and learn to use a different shortcut. :/

                    • 7. Re: shortcuts do not work on numeric keyboard
                      De Kruisbestuiving Level 1

                      I've looked quite a while for a solution and found one that worked for me.

                      Just duplicate the standard shortcut-set and save it (give it a name...).

                      Open the shortcut-set in textedit (on mac it's located at ~username ▸ Library ▸ Preferences ▸ Adobe InDesign ▸ Version 10.0 ▸ en_GB ▸ InDesign Shortcut Sets, for pc I have no idea)

                      Look for a shortcut by name, for ex 'fitpage' and change the standard 'cmd+0' to 'cmd+#Keyboard_Num 0' and do this (add '#Keyboard_Num ' between + and number for every numerical shortcut. Be sure there is a space after Num!).

                      Restart Indesign, make sure you are using your custom shortcut set and try them.