5 Replies Latest reply on Jul 30, 2014 9:21 AM by Peter Spier

    I lose words when i uncheck hyphenate

    HADRONCREATIVE

      Hello,

       

      I am now using Adobe CC InDesign.  In CS6 I usually create starts typing words to form paragraphs by dragging the Type tool to form a box and then the cursor appears so i begin to type.  Before I type I usually uncheck Hyphenate.  In CC when I uncheck Hyphenate the words extend pass by text box.  I need it to fit into my text box not disappear. The only option to seem my text is to make my text box bigger.  But i don't want to do that.  Can someone help?

       

       

       

      Best,

      Robinick

        • 1. Re: I lose words when i uncheck hyphenate
          Peter Spier Most Valuable Participant (Moderator)

          Are you using non-breaking spaces?

          • 2. Re: I lose words when i uncheck hyphenate
            HADRONCREATIVE Level 1

            HI Peter, Thank for responding.  No I am not, But I think it's a it's an InDesign CC Software issue with Mac 10.9.4?  if I try using text in InDesign I usually start with a text box, this text box will hold/wrap text within the box, but when I uncheck hyphenate, the words leave the box.  Has this happened you?

            • 3. Re: I lose words when i uncheck hyphenate
              Peter Spier Most Valuable Participant (Moderator)

              That's not normal behavior.

               

              When you say "leave the box" do you mean you have a red plus sign in the outport in the lower left corner of the text frame?

               

              Overset text when there appears to be space in the frame is caused typically by Keep Options set in the paragraph style that require lines to stay together, or by some setting that makes the text in a single line unbreakable and too wide to fit. Turning off hyphenation reduces the places that the text can break to spaces between words, so it is possible with narrow columns to have a single word that exceeds the available space. These types of problems are easier to diagnose if you open the story in the Story Editor. Select the frame and press Cmd + Y/Ctrl + Y (Mac/Windows) to open the editor. There will be a red line marking the point of overset, and the cause will be in the first few words that are after the line.

               

              Can you show us a pair of before and after screen shots of the text frame with hyphenation enabled and disabled, and non-printing characters showing?

              • 4. Re: I lose words when i uncheck hyphenate
                HADRONCREATIVE Level 1

                Hi Peter, Yes the red box appears...usually when I use text box and type past the box it does go red, but my text will go all the way to the edge of the box.  In this example it is not doing this, you will see a quarter of my content disappear when I uncheck hyphenate.  The text just goes away, leaving all this space.  This has never happened to me before, and I have used InDesign for 8 years.  But now I am using Adobe InDesign CC, and this is what happens.  Thank for your help:)

                Screen Shot 2014-07-30 at 8.49.43 AM.png

                • 5. Re: I lose words when i uncheck hyphenate
                  Peter Spier Most Valuable Participant (Moderator)

                  Looking at the screen shot it appears that the text is not quite the same in the two frames. The last line on the right starts with Nam, but it ought to be Faccus, so either there is something really strange, or that isn't the same text frame.

                   

                  I suspect a problem with Keep Options, possibly a combination of problems including the number of lines to keep together in the last paragraph that appears and something like keep ALL lines together in the next one, or a keep with next x lines. You should look at the keep options settings in the style assigned to the text, as well as the paragraphs individually.